Another V3 wierdness with PCAnywhere 10.5

Since applying CFP 3 via automatic update any time I visit a web page that uses java, including some javascript ads, windows installer pops up trying to reinstall PCAnywhere. This wouldn’t be a huge issue except that I have misplaced the installer files so I can’t just go ahead with the installation and find out if that quiets the problem.

Anybody else have a similar issue?

Yes, that has happened a few times with a variety of programs. Have you tried emailing PCAnywhere about the missing installer? They may be willing to help.

Actually, yes, I am experiencing something similar, though not the same. I recently went from Comodo Firewall v2 to v3 by doing a clean uninstall, then installing v3.

Now, every time I reboot or logout/login to my Windows XP SP2 box (fully patched), that pcAnywhere installer attempts to kick off. It’s irritating as all get out, and I’m trying to figure out how to squash it.

Yes, I have pcAnywhere 10.5 installed. It’s service is disabled (I long ago switched to using VNC for myself, using pcAnywhere only as a client, and that very rarely anymore). And there is absolutely NO reason I should have to re-run its installer for any reason.

If Comodo is kicking this off with each invocation of its UI, this is a bug and needs to be addressed.

I’ve dug through the Registry looking in all the usual places for where this installer is getting kicked off (HKCU and HKLM\Software\Microsoft\Windows\Current Version\Run, etc.), but so far no luck. Is it the actual Comodo program causing this?

I had the problem with a CD burner in the past, but I was able to fix it by re-installing the software. I think that the problem actually pre-dated CFP’s appearance on my machine, but it is likely due to a registry problem. I have had the problem again after installing CFP with an OCR program. It may be that the same kind of problem is caused by protecting the registry. Re-installing or repairing the installation re-writes the registry entries and CFP learns to allow access to those registry entries for that program. At least that’s my theory. Whether the problem is caused by CFP or not, my problem was solved in both cases by re-install/repair.

There is clearly a bug in the Comodo v3 (v3.0.13.268 in my case) install process.

As noted in this ticket, as well as several others (look up folks seeing MSIEXEC.EXE kicking off asking for the Dell Resource CD, or their HP drivers, etc.) including this one:

the problem that is occurring is that after installing Comodo v3, we are all getting some form of the msiexec.exe program kicking off when we login, and often at other times as well. In my case, the stupid thing kicks off 2x at login attempting to run the pcAnywhere 10.5 installer (which isn’t there). Then another 2x if I run Windows Update (translation: run IE and go someplace that triggers the msiexec process again somehow).

This is NOT a problem with my pcAnywhere install, which hasn’t changed in YEARS.
It is NOT a problem with people’s HP drivers.
It is NOT a problem with folks needing to reinstall their Dell Resource CD.
Even though certain parties who respond to many posts seem to indicate otherwise, they’re chasing their tails.

The problem is that the Comodo v3 installer is mucking with the Registry somewhere rather unique (and I’ll be darned if I can find it, as it’s not in the usual locations) that’s causing this to kick off. I believe Explorer, Internet Explorer, and possibly other apps may trigger this, but I can’t for the life of me find the ■■■■■■.

I went through the process of uninstalling Comodo v3, rebooting, and sure enough, the problem was gone. I had backed up my configuration before uninstalling, so I figured I could always get back to where I was. WARNING: This feature sucks and does NOT backup your entire config, so you have been warned. I’ll have to post that in another ticket, as I’m now stuck rebuilding my ruleset once again. sigh

After uninstalling/rebooting, I once again did a clean install of Comodo v3, rebooted when asked, and voila! The problem is back. So let’s just stop with the guessing game. The problem is Comodo v3, pure and simple. If you uninstall it and the problem goes away, and then reinstall and the problem’s back, that’s a glitch in the installation process. So please, those folks who are suggesting that users should go find their installation CD or re-run the installer of whatever app is being triggered, stop doing Comodo, yourselves, or the user community this disservice. That’s not a solution. That’s hearing a knocking sound in the car engine and throwing a monkey wrench at it in an attempt to “fix” the problem, insteading of going after the real root cause.

The real solution is to let the developers at Comodo know that there is a real bug in the installer, so they can kill the problem at its root. There seem to be several folks here in the forums technical enough to dig around a bit, but most users aren’t going to do that. They’re going to have this weird installer thing keep kicking off, get fed up, uninstall Comodo, see the problem has stopped, and head somewhere else. That’s a shame. And it’s avoidable.

Let’s find out what the hell this installer is doing exactly and fix that, shall we? Comodo Firewall is a pretty decent product with a lot of potential. It’s RAM footprint is nice considering what it does, and it has a ton of features. Unfortunately, as often happens in the development world, it seems they were more concerned with “kitchen sink” programming (throwing in every feature including the kitchen sink) than creating a stable, reliable program whose feature set might be smaller but worked well. Featuritis/bloat is something software companies need to be constantly on guard against.

And don’t get me started on the “noise” in the UI. Yes, Comodo does a great job as a firewall and now adding malware protection. But good lord, could you make it any more confusing? This program is fine for those of us who live on computers, but this sure doesn’t pass the “grandma” test.

So summing up, anyone finding this thread because they’re system is kicking up some kind of installer every time they login or run Windows Update (i.e., msiexec.exe), note you are not alone, and the problem is with Comodo.

Here’s hoping they find the problem and resolve it.

As I said, the problem may arise from the registry being protected. If you do a re-install, the Defense+ module learns that the section of the registry that it protects is accessed by that program and the problem goes away. You can unprotect the registry (by modifying the key sets that are protected) or give the problem program access rights to the protected registry (if you know which of the modules accesses the registry). Or you can re-install and fix the problem. At least that’s my story and I’m sticking to it. It certainly fixed the problem with my OCR software.

The Registry being protected by what? who? Are you referring to ACLs on individual hives/keys, or the registry as a whole?

To be clear, when you write “If you do a re-install” and “Or you can re-install and fix the problem”, you are referring to re-installing whatever app installer is kicking up after installing Comodo v3, correct? You are not referring to re-installing Comodo itself. It took me awhile to realize you meant re-installing the app which has its installer kicking up, as you wrote this just as vaguely earlier and it sounded like you were advocating re-installing Comodo itself, which clearly doesn’t work.

And if you’d bothered to read my post, you’ll see that my point is that programs such as pcAnywhere which were installed years ago and haven’t been modified should NOT be blamed for what is, no matter how you slice it, a bug in Comodo. Your “solution” isn’t really a solution at all. It’s a bandaid at best, and doesn’t deal with the root cause of the problem.

Besides, I thought the whole point of training mode was for Comodo to learn what a program uses/doesn’t use and allow the user to specify accordingly.

I applaud you for finding a “fix” that works for you, but don’t foist this on others as a real solution. Comodo needs to address this bug, as it will likely leave users with a very bad taste in their mouths.

Oh, and for the record, I have now found that MS Word causes this damn installer to kick up as well. This now makes the installer kick off

  • at login (triggered by explorer.exe ?)
  • any time you run [Start] | All Programs | Windows Update
  • MS Word 2003 (some kind of extension maybe?)

Interestingly enough, MS Excel and MS PowerPoint do not cause the installer to start running.

My gut tells me that whatever the Comodo installer is doing, it involves one of those gloriously intuitive class id values (the {acbd123…} keys you so often find in the Registry).

This got me thinking. If this is due to the “registry being protected” (which frankly makes no sense to me, as a side effect of that would more likely be a program simply bombing, not triggering an installer to kick off), then disabling Defense+ and the firewall, or heck, just shutting the whole thing down, should make such events go away, right?

No such luck. Even with Comodo completely shutdown, the installer still kicks off on login, and in my case any time you fire up Windows Update or MS Word 2003. And if you’re going to try and argue that the mere installation of Comodo somehow protects the Registry, I’m afraid I have to call b.s.

It truly feels like they’ve mucked up some setting in the Registry, possibly to some value representing a handler of some sort, that gets tickled when you login or do these other actions. I’m just having one heckuva time figuring out what exactly they’ve done.

Sorry if I was not clear before. I am only relating what I experienced. The problem that happened was similar to one that happened about a year back and again some 4-5 months ago and well before I ever installed CFP (msi installer wanted me to insert a disk to let it “Set up” Sonic’s DVD burner). It seemed to occur out of the blue - I don’t know what might have caused it. Uninstalling the program and re-installing using the install disk fixed the problem then. It happened again with my OCR install more recently after installing CFP. Again, it was fixed by using the installation disk and this time, it allowed me to repair the installation to sucessfully fix the problem. I am not sure of the cause, but the Defense+ module protects a number of critical registry keys. See Defense+>Common Tasks>My Protected Registry for the list of protected keys. This may be the cause. Any number of programs write entries into the registry as a normal daily occurrence. If you have set your security level to a higher level, those programs might not be given the permissions that are needed to access the registry. Out of curiosity, did you reboot after disabling CFP protection? I would expect that it would be necessary to do so to alter the registry protection.
There is a discussion of this topic also at:

As for the link, you might noticed I referenced the same thread yesterday in this thread. But no, haven’t tried rebooting after disabling CFP protection. Good idea, though. Will gave that a whack just to see if it makes the installer stop kicking off. I’m guessing it won’t, but whatever the case, if it helps build a pile of testing data that the CFP devs can use to isolate the bug, I’m all for it.

As I said, for the most part I really like this program. And I DO appreciate the fact Comodo makes this available for free. I’m not naive enough to think they’re doing it for the greater good, but even as a business model, I think it’s an honest and refreshing approach. So I’d really just like to help them fix this, because I’d like to see them succeed. (If I didn’t care, I’d just walk away and not say a word. But this program has such potential, and I like a company that puts its money where its mouth is, in this case by offering free software to show just how solid they are in security matters, hoping to make a name for themselves and thereby get business for their other offerings.)

Anyway, enough rambling. Time to reboot and see what happens.