An error occurred while setting the schedule. The schedule has not been set

i have an error message “An error occurred while setting the schedule. The schedule has not been set”

  • Your Operating System (and whether it’s 32bit/64bit);

Windows Server 2008
application Run as administrator
Login as administrator

  • Other Backup & Security Software Installed;

No other software, only Microsoft firewall

  • How you produced the problem;

setup a normal backup with weekly schedule

  • How you tried to resolve the problem;

set as administrator, give high security policy, couldn’t solve

  • Screen-shots with the error (if any);

Is the Windows scheduling service currently running on your PC. It is used to run the scheduled jobs.

Thanx panic for the reply.

Do you mean Task Scheduller? yes it is running

Sorry, I missed the fact that you’re running Win Server 2008.

The only O/S’s Backup is designed to run on are

Supported Operating Systems:

Windows Vista
Windows XP (Service Pack 1 or later)
Windows 2000 (Service Pack 3 or later)

This may have something to do with it.

Ewen :slight_smile:


i already upgrade CBU version 2.1.117500.10 from

And it is now support Windows Server 2008 OS, but i still got the same error as first post at this thread, anybody help? all condition in my server is the same as in the first post.


I’m having the same problem. I have the latest release and it is installed on Windows Server 2008 x64.


The latest public release is 2.1.118414.11
you can download it from forum or you can install the 2.1.117500.10 version (from website) and press check for updates.
The next release will fix the bsod problems.


I have pressed the Check for Updates button and downloaded and installed the latest version and still get the same error.


We need a few more details:

  • Is UAC enabled ?
  • does Diagnose in Settings tab says the application is installed correctly?


Installed Comodo Backup 2.2.127000.12 on Windows Web Server 2008 x64.

Running diagnose…

Checking if restart is needed…
No restart needed… OK!
Verifying your windows version…
Unable to determine your windows version!

any idea?


Please post a screen-shot with flowing key from registry using regedit (like in the attachement).


[attachment deleted by admin]

Here is the key from the registry as you request (in the attachement).

[attachment deleted by admin]


This was helpful. We will fix the issue in the next release.


Is there any news about this?

Thank You,


Here is a quick fix:

The next release will fix this problem.

Having this same issue…

HKLM\Software\Microsoft\Windows NT\CurrentVersion

“Windows (R) Small Business Server 2008”


This issue appears to affect ONLY the instantiation or editing of a schedule entry - I have just tested and confirmed that if i set the ProductName value to “Windows Server (R) 2008” and then create my entry, then set the Product Name back to “Windows (R) Small Business Server 2008” that the scheduled entry still runs - and I only need to change the ProductName value back to Windows Server (R) 2008 if I need to make a change to that entry.

Hope this helps.

Yes, the “ProductName” causes the issue.
We will fix it in the next release.


Having this same issue using version 3.0.164972.96

HKLM\Software\Microsoft\Windows NT\CurrentVersion

“Windows 7 Enterprise”

Other info: scheduler is running, this is a 32 bit OS, UAC is enabled



There might be another cause why scheduling is not working properly.
The “HKLM\Software\Microsoft\Windows NT\CurrentVersion” issue was fixed in 3.0
Please follow these steps to help us determine the cause of the issue:

  1. Go to Windows → Run type "cmd.exe’ and hit Enter
  2. In cmd.exe window type “C:\Program Files\Comodo\Comodo BackUp\CBU.exe” /enabledebug
  3. Restart CBU.exe
  4. Repeat the scheduling process
  5. In cmd.exe window type “C:\Program Files\Comodo\Comodo BackUp\CBU.exe” /dumpdebugcontent
  6. Collect the “Debug.cbu” file located in the “C:\Program Files\Comodo\Comodo BackUp” folder and post it here for analysis.


I’m actually getting the same issue as the original poster, but on a Windows XP SP3 machine that the scheduled programs used to work on just fine.

No other backup software.
AV: Kaspersky Anti-Virus 9 (tried both pausing protection AND killing the process).

Task Scheduler is running. I’ve also tried restarting it. Additionally, I’ve uninstalled Comodo Backup, rebooted, reinstalled, rebooted, and I get the same error message.

I have followed the steps above to capture debugging info, which I have attached it to this post.

[attachment deleted by admin]