Allow google desktop

I am unable to access my google desktop in firefox (or any other browser) . I Think this is because of comodo firewall blocking access to localhost .can any one please help???
??? ???

What rules are you using for your browsers? Look under Firewall → Advanced → Network Security Policy → Application Rules.

Can you show us a screenshot of the firewall logs? They can be found under Firewall → Common Tasks → View Firewall Alerts.

I am using firefox as my default browser. And the rules for this is : ALLOW IP OUT from IP Any to IP Any where protocol is Any.

For firewall log, there isnt any log for firefox or google desktop…Only there is one system in the local network of the school which is attacking my 445/5357 port . anyway i am attaching a screenshot.

thanks in advance

Are you referring Google Desktop Search program? It does not show up in the log you showed. May be filtering the log can help to retrieve message regarding FF for example. WHen in the log window push the more button for more extensive options.

Make sure that the firewall is set to create alerts for loopback. Go to Firewall → Advanced → Firewall Behaviour settings → Alert settings.

Can you also see if there are things reported in the Defense + logs (Defense + → Common Tasks → View Defense + alerts)?

yes. I am referring about google desktop search program. I am unable to search using google desktop. Moreover i cannot access the settings of google desktop also. I think i am unable to access localhost:4664. I am pasting a screen shot of the error found in firefox.
Yes, Its bizzare because there is no entry of google desktop in firewall log (i verified using the more option). Neither there is any entry in Defence + alerts.

Also i have verified that firewall is set to create alerts for loopback request. (screen shot attached)

Is it possible that earlier, when i didnt knew much about how to manage comodo firewall , i have denied access to google desktop ? ??? ??? ???

Can you delete the firewall rule for FF and let CIS make a new one? When that doesn’t help make FF a trusted program to see if the firewall gets in the way.

yes i deleted the firewall rule for FF. And when i started FF and google desktop, CIS asked my premission to access internet and And i allowed it…
But still i am unable to access anything of google desktop. i am still stucked at the same thing…

Should i reinstall firewall and erase all history of firewall ??? ??? ??? ???

Try temporarily disabling the Firewall. That can be done easiest by right clicking on the CIS shield in the Systray and choosing → Firewall → Firewall Security Level → disable it.

What happens now? Don’t forget to turn the firewall back on. CIS will not alert you about it.

no its still not working…is it possible that firefox/Comodo/Google desktop has some bug??

In your topic start you said it effected every browser.

Try temporarily disabling the Firewall.This can easiest be done by right clicking on the CIS shield in the systray → Firewall Security Level → now disable the firewall and try again. See if that helps or not. Don’t forget to enable the firewall again as CIS will not remind you.

Can you take a look in the Defense + logs as I described in the above?

yes, it is affecting every browser, so the problem must with either google desktop or comodo firewall…

I saw the defence + alerts, there are 2-3 alerts for firefox, but “target” is thunderbird or quicktime player…
there is one alert for google desktop where target is rundll32.exe

I already tried with disabling the firewall, but it is still not working

Can you show a screenshot of the D+ logs?

here is the screenshot

There are several alerts that draw my attention.

There are two alerts for rundll32.exe wanting to execute \User\VERMA\AppData\Roamin\Mozilla\Firefox\Profiles\zwhl…etc… that gets blocked. Usually you would get an alert for these type of actions. Next you get an alert allow it.

Also make sure rundll32.exe does not have a block rule for this. To do so go to Defense + → Advanced → Computer Security Policy → look up and select the rule for rundll32.exe → Access rights → push the Modify button behind “Run an executable” → look under the Blocked Applications tab and when remove the mentioned FF entrie when it is there.

The other alerts that raises an eyebrow are the rundll32.exe alerts for the GoogleDesktopCommon.dll and GoogleServices.dll. Make sure when you get a rundll32.exe alert for them to allow them. Also make sure there is no blocked rule (see the above on how to figure that out).

thanks …finally i m relived that the error is figured out… :slight_smile: :slight_smile:

but there is a problem, i checked the rule for rundll32.exe…there is no program that is in its blocked list…moreover, i have given a custom policy (allow all request, and ask for rest) …see screen shot…
i tried adding FF to its allowed program list, but that doesnt work…

i checked with Google Desktop.exe also…his rule is also the same…allow everything and ask if run as executable…


I will ask the other mods to take a look at your problem as well.

i uninstalled google desktop and then reinstalled it…but nothing happened…

also, i re installed comodo with latest version…after this, when i tried to access google desktop, several alerts came…like rundll32.exe and all…i allowed all of them…but its STILL NOT WORKING…

I am eagerly waiting reply… >:( >:( >:( >:( >:( ??? ??? ??? ???

Another angle: the Hosts file. The Hosts file (notice it has no extension) is a file used by an OS that will be used to look up IP addresses of url’s (socalled DNS look up).

The file can be found in x:\windows\system31\drivers\etc. Open it with Notepad and copy paste the upper part to this topic.

It will look something like this:

# Copyright (c) 1993-1999 Microsoft Corp.
# Dit is een voorbeeld HOSTS-bestand dat wordt gebruikt door Microsoft TCP/IP for Windows.
# Dit bestand bevat de toewijzingen van IP-adressen naar hostnamen. Elke vermelding
# moet op een afzonderlijke regel staan. Het IP-adres dient in de eerste kolom te worden
# geplaatst, gevolgd door de bijbehorende hostnaam. Het IP-adres en de hostnaam dienen 
# gescheiden te zijn door ten minste één spatie.
# Daarnaast kunnen opmerkingen (zoals deze) worden toegevoegd op extra
# regels of gevolgd door de computernaam, voorafgegaan door een #.
# Bijvoorbeeld:
#          # bronserver
#              # x clienthost       localhost
# Start of entries inserted by Spybot - Search & Destroy

As you see I am on a Dutch version of Windows XP…:wink:

I think the line localhost" may be missing.

Copyright (c) 1993-2006 Microsoft Corp.

This is a sample HOSTS file used by Microsoft TCP/IP for Windows.

This file contains the mappings of IP addresses to host names. Each

entry should be kept on an individual line. The IP address should

be placed in the first column followed by the corresponding host name.

The IP address and the host name should be separated by at least one


Additionally, comments (such as these) may be inserted on individual

lines or following the machine name denoted by a ‘#’ symbol.

For example: # source server # x client host

::1 localhost