AliExpress no longer working in CID

Since yesterday, I am unable to get any search results on when using CID. At first I thought the problem was at their end but I have tried in Firefox and Chrome and both work perfectly. Can anyone else verify if you are able to get search results on please?

Hello 7Leagues, it works fine on my side, u can try clearing the cache from: Options / Privacy & Security - Cookies and Site Data - Clear Data

Hi Sergiu,
Well I cleared the cache as you suggested but I still can’t get any search results. Do you have any other suggestions?

I am able to get search results in Firefox and Chrome but I noticed that no matter which page of results I select, they are always the same. I also tried placing an order several times and consistently received an error page. This leads me to believe they have made changes to their site which have broken it. Could you just run a search for any item you wish and then see if the results change when you select the next page please?

It works for me i have tried on a few OS’s
Flash Deals Works, redirects to correct page

Search field work redirects to Search input, and page

i go to, maybe you are using a clone of it or smth

No, I’m definitely on their site. Here’s what I have in the address bar:

I also tried just

In both cases, I get absolutely nothing in CID whereas I get a page of results in Firefox and Chrome. However, when I select page 2, 3, 4, etc. the results are identical.

It’s very odd, maybe u have a add blocker or smth that may compromise ur search…

I have Adblock Plus and Ghostery in CID and Firefox but I turned them both off. In Chrome I have nothing.
So, are you saying you get different search results for each page?

AddBlock may interfere with your pages,
I do not have any problems with my searches, it works fine, tested on 4 different machines all fresh installes…at a last resort u can try re installing it

AdBlock is turned off for the AliExpress site.
I restarted the PC. No change.
I then reinstalled CID and again restarted. No change.
Next, I ran up my previous laptop with Win 7. In CID, search worked but placing an order wouldn’t. Indeed, I got the same error I have had with this machine (see attached photo).

The fact that the other laptop at least performs searches correctly tends to suggest that I may have a virus on this one so I’m going to try restoring my system to its state yesterday when everything worked as it should. I will let you know how that goes once completed.

it is a odd problem, i have forworded this issue to the dev’s aswell i want to hear theyr opinion on the matter

It gets even stranger!
After restoring my system to its state yesterday morning when all worked as it should, I still cannot get any search results when opening But, I already had a few pages open with different results from yesterday and if I use those to continue to the next page, it works. Considering I cleared my cache again, none of this makes any sense.

It is still impossible to place orders but that applies to both machines leading me to believe they may have troubles at their end. It’s not even a payment refusal; the Buy Now button always gives the error page I showed you earlier.

Well they are asleep now so I will have to wait until tomorrow. That said, AliExpress refuse all contact with customers unless it comes via their AI bot “Eva” and that won’t allow you to discuss anything technical.

After plenty of further research, I have discovered that the problem has nothing to do with CID or any other browser. I am able to search and purchase from any other seller I wish to. It is only with that particular seller that I get the error page when attempting to purchase his products. I therefore conclude his account has been blocked for some reason.

If AliExpress had notified potential buyers that this was the issue rather than showing their stupid “Oh no! The internet is broken” page, it would have saved loads of time and frustration and have prevented me from looking in directions that have no relation to the issue at hand! >:(

Sorry for having wasted your time Sergiu. :-[

Hello, 7Leagues glad it is solved