Alerts not working

The firewall does not alert me on some of the new connections: e.g. when opening internet explorer the first time, it alerts on the several ip addresses to go to the home page ( but when moving from page to page in the internet explorer it doesn’t ask for permission visit the new IP addresses. I do enable “remember the answer”. I checked firewal rules and they are empty. I have alert settings on high. The problem seems to be that it does not “ASK” on new connections on already running applications.

Are you running the Proactive Security configuration?

You need to enable Create rules for safe applications . Otherwise CIS will apply a default allow all outgoing traffic rule.

Take a look at this thread. See if it helps answer your question.

I have the exact same problem as the described in the thread pointed to by Radaghast. Apparently this is bug

Unfortunately, It would seem so.