Agent won't install: Products Initialisation failed

I took the 10 pack licenses.
I installed the Endpoint security Manager on a Win 2012. All good.

In the packet there is also a folder named Agents which under windows folder has these files:

I tried to install this by running Setup on the same server i installed the ESM above mentioned.
It askes for the server host: and Server port:
I can successfully ping the server. I can successfully telnet the port on the server
port is 9901 as shown in the Comodo ESM Configuration Tool

It gives me the error:
Products Initialisation failed instalation cannot continue

I tried this on a windows 7 and it gives me the same errors.

Help me out because it’s driving me crazy and i must make it work ASAP as the environment is about to be entering production in 3 days and we want to buy around 200 licenses if i make this work.


Please use the ESM Agent offline package , which is available under Preferences->Packages

Have you tried the push installation of the agent and CES?

I used the first option in the end and worked, then i saw your answer and it confirmed.

Now, the problem i encounter is that i cannot add endpoind client on the self server - the one with the ESM.

i do like this:
Computers-> Add ->Active Directory->… i find my computer there → targets summary → credentials → endpoint security

now, here, all is grey. it writes that there are no CES packages in the system

i check in the folder and under Packages indeed there is nothing there.
I thought that when i download the 10 pak free all is there.

So, i must download something else separately?


Please make sure the CES package is downloaded
Preferences->Packages ->available packages->check for updates. If it’s not downloaded, Click Download Updates.
Wait for the packages to be downloaded and try again.