After years of usage: "Security agent could not started" - tried v10.0-10.2


I am using CIS since years, latest version installed and functional was v10.1

But since three days I got the error message “Security agent could not started”.

The diagnostic tool shows no failures.

I didn’t change anything at CIS, must be something within the last update or the other windows environment.

What I’ve done so far:

  • first I though I got infected. But after several scans with other AV tools (Clamwin AV, McAffee Stinger, Comodo Cleaning Essentials, Norton Power Eraser, Dr. Web CureIT, Spybot S&D) I’m pretty sure there is no infection.
  • then I tried to undo the last changes at windows I remember so far which means I uninstalled some software
  • last thing: I uninstalled CIS and reinstalled (after cleaning with official Comodo cleaning tool). Installation without problems, computer restart, “Security agent could not started”. Tried safe mode, but same error message, but nox the diagnostic tool found some unrecoverable errors (without showing me which errors, but I created a log). Next: uninstalled and tried the actual CIS v10.2 and after that (same error) the older CIS v10.0. But same situation here. “Security agent could not started” without errors within diagnostic but in safe node some unrecoverable errors.

So maybe anybody has an idea what’s wrong?

Hi Stefanseiner,
May you please check using latest Comodo Internet Security v10.2.0.6514 ?

There are several fixes in it.


same with this version, I tried the latest, online and offline installer

Update: still no solution.

I tried:
Comodo Antivir as standalone installation (same error) and, after uninstall, the COmodo firewall standalone but still “security agent could not started”

Now I cleaned all files and services up, removed all other antivirus software and tried a fresh CIS v10.2.0.6514 installation but still same error.

As I can identify all important Comodo tasks are running

Hi Stefanseiner,
Please try following steps and let us know if it solved the problem:
Step - 1: Try to launch CIS interface from desktop shortcut, if doesn’t work try step-2.
Step - 2: See if you can locate CIS tray icon in system tray, exit and try to launch CIS interface as mentioned in Step-1, if doesn’t work try Step-3
Step - 3: Locate cistray.exe in TaskManager, terminate and launch CIS interface as mentioned Step-1


Hello, Stefanseiner.

Your issue is under investigation. Could you please check your PM and provide us requested logs and information. Thank you in advance.

Kind Regards,

Thanks for this try, but after following this steps two times still no working CIS. Just the comodo diagnostic which is starting without any result

Thanks, PM with requested infos is on the way