After v3. Firefox won't print from web

Hi all. Newbie here first time. Have been a Comodo user for quite a while and just upgrade to V3.0.16.295.

Since the upgrade, I have been unable to print from any web page while using Firefox. Am able to print from all other sources, including IE7. I have tried other forums (Firefox, PCQ&A etc.) to see if there are any other answers to my problem with no success. Seeing it happened right after the upgrade it may have something to do with the newer version of the firewall. Any help offered is much appreciated.



Had the same problem (or at least the same symptoms). Check to see if you have an event logged in the Defense +. In my case Firefox was being prevented from using spoolsv.

If this is the case you’ll need to go into the Defense+ Settings (under Advanced) and remove this from being blocked (I believe under Coms interfaces (?) there is a Modify button that opens up a table with Allowed and Blocked entries). Removing the Blocked entry will suffice i.e. no need to add to the Allow assuming you’re in Clean PC or Train with Safe Mode. This is what worked for me.

Sorry I don’t have the exact steps as I’m working from memory and currently don’t have access to CFP screens or the help files. Since you hadn’t yet drawn a response I thought I’d give you something to get started. Assuming this is your issue maybe you or some moderator can clean up my rough draft.


Once again, a little more clear this time …

Under Defense+ > Advanced > Computer Security Policy

Scroll down under All Applications to C:…\Firefox.exe, select and double click to edit the policy

In the new window click on Access Rights and in the new window click on the Modify to right of Protected COM Interfaces. Then click on the Block tab and if spoolsv is listed there remove it.

This worked for me although I don’t understand how spoolsv ended up in the Blocked Coms interfaces. May have been something residual from a previous install although I did clean the registry prior to installing.

Hope this helps,


Thanks Birdman. For whatever reason, the problem fixed itself, right out of the blue. Strange indeed. As it turns out, I updated to the newest version today and everything is as it should be.