After upgrade of CID lost all bookmarks and can't restore - please help [Merged]

I am a newbie to Ice Dragon. I downloaded it to give it a try and then get a licence etc. Yesterday I got a message to update Ice Dragon and followed the instructions to do so. This morning when I opened Ice Dragon all my bookmarks are gone. I tried the restore bookmarks process but the bookmarksbackup folder has no files. I right clicked to get previous versions but it indicated there are no previous versions. Are bookmarks at all recoverable. Please help.
Mod edit: Added merged to the topic title, Captainsticks.

Hi and welcome akk467,
Check the following location to see if you have two profiles listed?


Thank you so much captainsticks! I did not find the file in the exact location you suggested but I did find it under AppData. I was able to recover my lost bookmarks.

So the problem is resloved.

Thanks again!

Hi akk467,
I am so glad to hear that you have recovered your bookmarks. :-TU

Kind regards.

Each time I get an update to ID and install it, all of my bookmarks are gone along with my addons and services. This is the second time in as many updates that this has happened… What gives? Fortunately I have a backup (having learned before). This is a real pain in the A$$.

Hi dmking99,
I have merged the above topics, because I think the issues are related and possibly a second user profile is being created.

I have informed Staff of this issue.

Thank you.

Recovering the bookmarks isn’t the issue. The issue is that on an update ID wipes out ALL of the previous setting, information, bookmarks, services, etc. Is this a feature? So it’s like a brand new install. All other browsers that I use, update and leave the user experience and setting as they were. Updates should happen behind the scene and not intrude on the user experience.

At this point, I’m planning to move over to Opera. Fool me once, shame on you, fool me twice, shame on me. This won’t happen again.


Icedragon unknowingly updated a couple a days ago and upon booting up next day, icedragon was changed. I lost all book marks, bookmark tool bar entries gone, passwords gone, settings all reset and theme reset.

I tried the advice above but found no appdata. I know I’m ■■■■■■■ now. WTF! :-TD :o

Show Hidden Files and Folders in Windows 7, 8.x, 10, or Vista is your friend. The appdata folder is hidden with default Windows settings.

I did the view all folders and appdata was there but any momento of the previous browser set up was missing. It showed profiles 8/19/15 with another folder in the profile folder named n7jgf07u.default 4/22/16




4/22/16 6:09 pm when it was updated. Everything is gone.

Then I am out of options I’m afraid. From what version did it update its self?

I’m choosing to reply here rather than start a new topic since this is the first one that came up when I searched for the problem; I imagine others with the same issue will likely see it, too.

I’m having the same problem as described above. CID updated to version (I just submitted a help ticket to another website a couple of days ago so I know my version previously was When I launched CID this morning, all of my bookmarks, cookies, and all other personal settings have been wiped out. As another user said above, it was as if I’d uninstalled CID entirely and performed a clean install.

I’ve managed to restore my bookmarks via the backup file under the profile directory, but this is annoying to say the least and is apparently not an isolated issue. Is there something I can do to prevent this happening again?