After installing Comodo AutoCAD LT2006 stopped working

So…As the title says. After I installed comodo (free version) AutoCAD LT 2006 started to CTD about 10 seconds after it had started. It gave me just enough time to open a drawing and then CTD. Comodo is definetly the reason since after I uninstalled Comodo the CAD is working again. I can always use Avira antivirus but I need a firewall too so Id rather use comodo if there is a workaround for this problem.

Can someone help me with this please?

Welcome to the forum!

Open CIS-Defense±Advanced-Computer Security Policy

Delete the rule therein for Autocad

Rightclick on CIS tray icon - Defense+ Security Level - Select Training Mode

Run Autocad

CIS will learn how it works and will create automatic rules for AutoCad without giving you any troubles. It is worth re-installing CIS as it protects you very much.

(It is my suggestion that to avoid pop ups and problems, you may change the defense+ security level to training mode and run the normal programs which you require to run once and then change the defense+ to safe or clean PC mode. It will give you less pop ups.)

Thank you for your very quick reply

I’ll try that. Thanks. I’ll let you know how it worked out

No joy. AutoCAD still chrashes to desktop. I also tried adding it to the trusted programs list. Didnt work. Tried adding autodesk to trusted program manufacturer list. Didnt work. Even if I shut down comodo completely the problem doesnt go away.

Is there anything else I can try? It seems there is somesort of conflict with these two and only way I know how to make AutoCAD work is not having Comodo installed

Just Check After Disabling D+ Permanently And Update Us

[attachment deleted by admin]

That worked ;D Thank you very much.

But I kinda wanted this program just because someone recommended me that defence + is very good. But atleast I have a firewall and antivirus now. Maybe in the future there will be a fix for this. I hope :slight_smile:

Without checking your d+ log and rules, we will not be able to confirm that its a bug/conflict. I know that you have added it to your trusted list, However it might be stopped even because of some other executable which autocad tried to execute and it could also be the one which you might have not removed from the rules before setting d+ to training mode.

Yep…You are certainly right. :slight_smile:

I’m still a complete newbie with this program (and with firewall/antivirus setting alltogether). But if you point me the to the right direction so I can find the logs I’d be happy to send them for you if you want to take a look at them.

Definitel I Will.

Before we start i would like to have some more information regarding this issue.

  1. As You Have Mentioned That Its Started Occuring After The Installation Of CIS, I Would like To Know Did You Received Alerts When You Tried To Open Autocad For The First Time After The Installation Of CIS ?
  2. What You Did With The Alerts. Did You Allowed All The Alerts or Denied Some Or Just Closed The Alert Window ?

Yes. I did get alerts. And as you said the autocad uses many more exe files when it runs.

In short…I allowed everything. And here is the longer version of it too…

All exe files I know Autocad to launch are:

It first asked if I wanted to allow the execution of acad.exe I answered yes.

Next the acad.exe was launching AdskCleanup.0001.exe. its always running the same time as the acad and I told it to allow this too.

Then acad.exe lauched the updater WSCommCntr1.exe for the autocad and I also allowed that.

I dont think comodo asked anything about AdskScSrv.exe.

The AutoCAD started up just fine. no problems there until I opened up a drawing and started working. At the second I tried to use any command within AutoCAD. Thats when it chrashed. I even left it untouched for a while and it didnt chrash until I tried to use some command in AutoCAD.

Can you show us a screenshot of the D+ logs? They can be found under Defense + → Common Tasks → View Defense + events.

Never uploaded any photos anywhere before…lets hope this works :-\

Aaaaand hopefully I took the screenshot from the right place 88)

Didnt know how to make it smaller but feel free to edit my post if its not appropriate.

AutoCAD LT 2006 has some memory allocations issues and triggers the buffer overflow protection in CIS when you open some drawings. This will not appear in D+ logs.

You can enable and use Defense+, just turn off buffer overflow protection (D+ - advanced - image execution - Uncheck “detect shellcode injection”).

I would not recommend that he truns off buffer overflow protection, it would be better to exclude the AutoCAD folder from Buffer Overflow protection (D+ - advanced - image execution - “exclusions”).

I have some extra features too in my AutoCAD. Its RakLT2006 (Rak means Stru as in structure). Would this be the way to do it?

Yup thats correct, does AutoCAD work now?

Yes it works now ;D Defence+ is enabled and everything seems to work just fine. :-TU Thank you all for your help. Much appreciated.

Just a question did you get a Buffer Overflow alert before you added AutoCAD to the exculed list? and did you do a upgrade or clean install to 3.9?


Sorry Im not 100% sure about the buffer overflow alert but I dont think I did. It is possible that I did tho…I just cant remember

I did a clean install. Never had comodo installed before.

Hi Guys,

Interestingly enough Rajeev’s new thread about Autocad 2010 is here
and I referred him to this one
He confirmed that he is working with v4, but…

Probably Eric will split this thread so the discussion about Autocad 2010 & CIS v4 will be handled in the new thread (???)