After install and first run of Comodo Cleaner, Windows XP will not boot

After install and first run of Comodo Cleaner, Windows XP will not boot.

I tried running in safe mode, stops loading at Loading MPU Drivers.

I tried repairing, but still does not load.

I am running Windows XP Professional SP3. Please help, I don’t want to have to rebuild this PC.

  • Your Operating System (and whether it’s 32bit/64bit);
    WINDOWS XP Professional 32bit SP3
  • Version of Comodo System Cleaner used;
    Just downloaded it, so whatever most recent build is.
  • Security Software Installed;
    PC Tools Threatfire, PC Tools Antivirus, Comodo Firewall+Safe Surf+Defense
  • How you produced the problem;
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • Post Memory Dumps on crash if you encounter any;
  • All log files of CSC, if you had logs enabled;
  • Any other Additional Information.

I have exactly the same problem. I just installed the Comodo system cleaner, ran the registry cleaner and now my PC will not re-boot.

The recommended solution was to delete CRPF.BIN CSDF.BIN and CSDF.SYS from the windows\system32\drivers folder, however, I do not have all these files.

I do have a CRPF.BIN in the Windows folder and a CSDF.SYS in the windows\system32\drivers folder. I do not have a CSDF.BIN file at all.

I removed the CRPF.BIN from the windows folder and the CSDF.SYS from windows\system32\drivers and it will still not re-boot.

Please help. Starting to seriously panic here!!! My config is the same as the person above.

…an update.

I also found a CRPF.SYS file in the windows\system32\drivers folder. I deleted this too, even though it was not part of the solution… and thank the Lord, my PC then rebooted :slight_smile:

First action was to restore the old registry and uninstall Comodo System Cleaner.

Guys… I know its free and I appreciate that, but I don’t have heart problems right now and don’t want any anytime soon!

First, you need to gain access to your system.

Once you are in your system, go to Windows>System32>Drivers and delete these 2 driver files: CRPF.SYS and CSDF.SYS.
After you delete these files, restart the system and enter in your Windows. Windows should load and start normally as before.

This problem will be fixed in our future releases. We are sorry for the inconvenience.
Thank you for your support.

Posting this in case it will help other users solve this problem. I had the same experience when installing XP and running csc (hang at the logo). I tried a lot of things and nothing worked so I reinstalled xp…

Then I forgot all about it and ran csc again some weeks later (since it works on our stationary xp and on our other notebook vista I did not consider it).

The problem with “accessing the system” is that if you like me have a downgraded acer travelmate 5530g then you need to get the ahci-drivers to work. I used bartpe a slipstreamed sp3 cd with the achi driver and poweriso to add the achi driver to the bartpe iso file before creating the cd (or accually tried tons of things before I got this to work).

Then I booted bartpe and removed the mentioned files. Then the system worked fine. Good thing I read this post because after 4-5 h of problems with creating the bartpe cd I was about to give up again.

Thanks for great products…

:frowning: Help! my windows xp won’t restart after running comodo cleaner. I have to turn it off then on again for it to start. I made the mistake of finalizing after I turn it off and on again thinking it was a fluke. It wouldn’t restart using the restart button. Restore did nothing. I deleted crpf.sys and csdf.sys and it did not help.


Please tell us what version of CSC have you used, what operating system are you on, what antivirus/firewall/anti-spyware software have you installed and what exactly did you do before finalizing CSC cleaning.

Thank you for your support.

version of CSC is 1.1.64946.38 windows xp sp3 Zonealarm Internet Suite. I ran CSC then restarted windows to find it stuck on a black screen with single curser in left corner of screen. I tried to ctrl, alt, delete it and it went back to black screen; tried esc and f10 restore with no response. I then turn of the CPU and reboot it and it booted fine. I thought it was ok so I finalized it. Then tried to restart and it would not restart. My restore says that previous restore is the same as it is now. Windows still will not restart but I can shut down completely then reboot.

When nothing works try this nifty procedure to do system restore with a detour: . This method uses the installation CD, the repair option of the installer with command prompt and works when you are totally locked out.

I appreciate your time. I’m sorry but I think I found the problem. I was running windows defender and zonealarm at the same time. I am not sure if that is the reason but when I turned off windows defender it would restart.



That problem was caused by Zone Alarm conflicting with CSC. It is already a known and proven fact from a long time. If you’d like, you can read the discussion concerning the problems encountered running CSC when Zone Alarm is installed:

There are other threads too about complaints involving CSC and Zone Alarm. Depending on the settings used to configure ZA, it may block CSC’s functions. It’s the way this firewall functions with all CSC like software that digs deep into the registry and other Windows protected areas by ZA.

Thank you for your support.

Hello, I’ve had this problem too on my 32-bit Windows XP Home SP3 machine but after that chilly feeling down the back of the neck when my computer didn’t start, I calmed down, rebooted, got the “Windows did not start normally” screen, and selected “Restore last known good configuration”.

Hey presto its all back to normal.

And yes I know its free software but HOW did a fault as crashingly obvious as this get through testing??? I suppose the idea with distributing a free system cleaner is to boost your company’s public profile but this sort of thing really isn’t a good advertisement for Comodo’s products! A shame, because apart from the fact it doesn’t work, it looks like a good and thorough product.

Very much looking forward to Comodo’s future releases of this software. Wish you well.

As my colleague Adrian pointed out, the conflict between ZA and CSC is a known issue for version 1 of CSC.

In general, software conflicts take place when two programs compete for the same resource. ZA tries to protect the registry while CSC must read and write into the registry in order to do its job. When this is prevented by another software (like ZA in this case) a software conflict takes place. And the effects are a non-loading Windows.

That is why we recommend the latest version of CSC: which doesn’t conflict with ZA and has major changes.

Thank you for your support.