Adobe Updater problem [RESOLVED]

I tried to use adobe updater to check for updates, the application says it’s waiting for an internet connection, however I’m never prompted to let it through.

Perhaps the application’s name already on CPF’s list, then?
Have you check the Activity tab to make sure the updater is on the list?

I didn’t find it on any part. Not on applications list, not on activity, and nothing in log.

I didn’t try disabling the firewall, as soon as I find where I stuck that laptop, I’ll try that to see it connects that way.

Sorry about the double post.
Found my laptop, set firewall to allow all, and tried again, no luck.
It would appear something about Comodo prevents Adobe Updater from detecting a net connection.
This happens on two laptops.

I tried in on a third which is using Zonealarm still and ZA prompted me to let it through and it worked fine, so only conclusion is Comodo is blocking something it needs to detect a net connection. What bothers me is that I’m not getting any log entrees.

EDIT: I also tried manually adding a rule to allow the program unconditionally, but still no luck.

Sorry once again, please mark this as resolved. After doing some more checking I found the real problem. It appears that IE7 breaks Adobe Updater. Both computers with Comodo also have IE7.

Sorry about that.

Glad to see you found and solve the problem.
…I think this should be on the FAQ list.

I also have this problem.

I turn off Norton security but the problem persists.

What exactly is the answer to this problem?