Adobe PHOTOSHOP application seems to be untrusted

I have a PC using just the Comodo Firewall product. It seems that Adobe Photoshop CS3 is unrecognized and I add it to the trusted applications manually. Now it seems the program will not save when working on a project the Photoshop application freezes. Now I did set up Firewall as instructed here with exception of setting “Treat unrecognized files as” is Restricted and not Block because I not as paranoid as the author of the web site. Any ideas or advisement on this?

Hi neftv,

Photoshop should be recognised and trusted by CIS. Please make sure photoshop.exe has a valid digital signature (right-click > Properties), and that Adobe Systems Incorporated has not been removed from Defense+ > Computer Security Policy > Trusted Software Vendors. You can also go to Defense+ > View Defense+ Events to see if Defense+ has blocked anything Photoshop has tried to do.

There are 3 Adobe entries in the Trusted vender list.
It strange I add the photoshop.exe to trusted programs and exclusion and it still comes up as unrecognized. In the Defense log all I see it do is install hooks but I don’t see any blocked activity. It Photoshop CS3.
When I right click to get properties on Photoshop.exe it says its from Adobe Systems Inc, Copyright 2007 File version I don.t see it saying signed anywhere.
Every time I click on photoshop it comes up as unrecognized. I put the file in exceptions in execution control center and in trusted files. I don’t know what gives here. I can’t submit photoshop.exe Comodo says its to large.

There seems to be no way to operate Adobe Photoshop properly with Comodo Firewall in Internet Security Mode or Proactive mode. Even after reinstall of Photoshop CS3 which ended up as Version 10.0 still had problem of being sandboxed and not recognized in Comodo Firewall. So I reverted Comodo Firewall to Firewall mode till I get some ideas here. Otherwise on this particular system I will have to use another product. Thanks for suggestions.

I think it’s ironic that Photoshop isn’t trusted…after all, how can you trust a picture once Photoshop has had its way with it?

Its not that it isn’t trusted as soon as I execute photoshop.exe Comodo takes it to the unrecognized listing and ends up in a Sandbox. I put this photoshop.exe in the trusted section and exempt section too as stated in my previous post yet it comes up as unrecognized every time I launch it. Can a file change? I guess I am other only one that uses photoshop with Comodo though.

Go to Defense+ → Computer Security Policy → Add → browse to the Photoshop.exe and Use a Predefined Policy: Installer or Updater.

If it does not have a valid digital signal, something is wrong with the file.
Can you reinstall or repair Photoshop? :slight_smile:

this is the solution… worked for me… thanks!!

Well said. ;D


I get a warning whenever I attempt to run Photoshop (both 32 and 64-bit versions). Yes, I have a legal, licensed copy.

A couple of things here:

First, I thought perhaps this might have something to do with the validity period of the signing certificate for photoshop.exe…the validity period for Adobe’s certificate has expired. I don’t believe that is an issue, given that the validity period would presumably apply to when the .exe was signed (at which time it would have been valid…the date signed is in May, 2010 and the expiration was in December, 2010).

Second, Comodo issues the following warning before allowing Photoshop to run (the warning contains the bold text as shown below):
"Although Adobe Systems Incorporated has digitally signed their application, they are not yet whitelisted by us. If you trust Adobe Systems Incorporated and are installing or updating their application, you can press the allow button.

So, it seems that this has something to do with Comodo’s whitelisting. Also, why would Comodo consider this an updater or installer if it’s the program file itself rather than some update utility?

Note: I have no idea…that’s why I’m asking :wink:

Thoughts, please?

When I tried to add photoshop.exe to the trusted vendor list Comodo would not let me. It says it don’t have a valid signature. When I tried to Go to Defense+ → Computer Security Policy → Add → browse to the Photoshop.exe and Use a Predefined Policy: Installer or Updater. This helped but it don’t give full functionality to photoshop, it ends up locking up.
This Photoshop CS3 look to be a valid, it has the key code on the case and the Adobe logo on the case. Any more ideas? This application works fine when Comodo is in Firewall mode only.
Thanks again.


Submit the file to Comodo Lab, if it is safe it’ll be added to the white list.

To submit the file :
==> Defense+ > Unrecognized Files > Add > Brownse and then Submit.

Don’t forget to remove the file from “Unrecognized Files” before leaving this section.


I would love to do that but the file is to big to send so Comodo says.

Can you give us SHA-1 for Photoshop.exe? You can use Comodo File CRC (attached) to get SHA-1. :slight_smile:

[attachment deleted by admin]

The SHA-1 appears as 6CF777FB9A6C44A2DF8898DE9D3F985F169FAC28.
I probably wont get to this computer before Monday again so hopefully it will be ok by then. Till then I will leave Firewall only mode. Please let me know if I need to do anything special here.
Thanks a bunch.

Thanks. :slight_smile: I searched for that SHA-1 in Comodo File Intelligence, and it says the file is safe (but not digitally signed, sorry :embarassed:), so it should be trusted by CIS.

File version: 10.0 (10.0x20070321 [20070321.m.1480 16:39:00 cutoff; m branch]). Does that mean the 10.0.1 update is not installed?

I will have to update Photoshop to 10.0.1, in the mix of what I was doing I did a reinstall of Photoshop.
So what that mean it safe but not not digitally signed so Comodo don’t trust it?
I would imagine a lot of people use Photoshop, and not everyone can afford to always have the latest software with everything. So does this mean I can’t run Comodo in full force with Photoshop even as 10 or 10.0.1? What gives?

I did the update to 10.0.1 and the new SHA-1 is A91917B6AD936C6DAA7EE5C29E438076A4C1C1B5

Is that on your system?

Comodo File Intelligence says it is safe, but my CIS does not recognise the file (I extracted it from the installer/updater). Also KillSwitch says it is unknown. :-\