Adobe Flash Player won't upgrade/update

I have tried this 4+ times now and I can’t get it to update/upgrade on Comodo Dragon …

The reason I am trying to upgrade is when I do the right click on the adobe flash window and go to “about” it tells me that the version I am using is and the Adobe site says the current version should be …I went to the actual Adobe site manually (not via one of those pop-up windows that tells me to upgrade) - I download the one ‘for other browsers’ (have also tried to install the one for Chrome since Comodo is Chromium based) - I totally shut down Comodo and then install Adobe Flash Player and then reopen Comodo and lo-and-behold … Adobe Flash Player is STILL in version WHY won’t it update/upgrade? I have cleaned out all the caches, browsers, temp internet files … etc etc… have even tried rebooting the computer and even doing a disk cleanup and disk defrag (out of frustration, if nothing else) … nothing seems to have it show the update/upgrade. This is ridiculous. Am I missing something?

When I go to the “About” for Comodo Dragon, it tells me I am up to date:

Comodo Dragon is up to date.

Please help/advise … I’m at my wits end. :-\ ??? :o :-[ :-\

Thanks in advance.

Hi WillowRaven,
Do you happen to have an older version of ‘PepperFlash’ in Dragons installation folder, or Chrome installed on your system which maybe outdated?
If yes to either of the above, PepperFlash (PPAPI) could be overriding the standard Flash (NPAPI) plug-in.
Check Dragon’s plug-in’s and expand the details to confirm what versions are installed.

Kind regards.

Hello and thanks for responding…

I checked my Chrome first and it tells me it is current:

Version 33.0.1750.146 m
Google Chrome is up to date.

however when I go to the pepflashplayer.dll (in the Chrome folder) and right click/properties, it tells me for version: Shockwave Flash 12.0 r0

Furthermore, I go to dragon://plugins and see:

Adobe Flash Player (2 files) - Version:
Shockwave Flash 12.0 r0
Name: Shockwave Flash
Description: Shockwave Flash 12.0 r0
Location: C:\Documents and Settings\Owner\Local Settings\Application Data\Google\Chrome\Application\33.0.1750.146\PepperFlash\pepflashplayer.dll
Type: PPAPI (out-of-process)
MIME types:
MIME type Description File extensions
application/x-shockwave-flash Shockwave Flash .swf
application/futuresplash FutureSplash Player .spl
Name: Shockwave Flash
Description: Shockwave Flash 14.0 r0
Version: 14,0,0,145
Location: C:\WINDOWS\system32\Macromed\Flash\NPSWF32_14_0_0_145.dll
MIME types:
MIME type Description File extensions
application/x-shockwave-flash Adobe Flash movie .swf
application/futuresplash FutureSplash movie .spl

How can this be when I’ve updated this at least 4 times in the last week?? I’m guessing the Adobe updates do nothing for the pepflashplayer.dll file? If not, then how do I update this particular file? In Chrome, it says nothing about it needing to be updated, however that version is vastly different from the Adobe Flash version (which is

Hi WillowRaven,
You guessed correctly, updating Adobe Flash (NPAPI) does not update PepperFlash (PPAPI).

You will have to update Chrome to update PepperFlash, I am not sure why your Chrome is saying up to date at V33.0.1750.146.
Current stable version of Chrome is V36.0.1985.125.
Google Chrome release history-Wikepedia (Click show to expand)

Kind regards.