Activation Error (Again) Resolved!!!


An error has occurred. Error -2146697211: Unknown error, please contact support.

This is the third time i installed CPF and uninstalled CPF, installed again a new BETA, enter my program settings again and again (New BETA lost my old settings !!!)

Current installed Version = error
Switched to security level 'Allow all" => error

Very very frustrating!

My System: Windows XP Professional SP2
RAM 384 mb, available RAM 20%

Sorry to hear that you’re having trouble. Have you tried doing a complete uninstall using these instructions from the FAQ? It could be something is still lingering somewhere.,302.0.html,873.0.html


Made a complete uninstall and a new install of last beta version.
The same effect: activation error as stated in above post!

HPJ: Strange - I’ll ask one of the developers to jump into this thread so that we can diagnose further.

Hi Guys,

We are aware of the issue and trying to find all possible reasons. That error can be caused by many factors. We are on the issue and going to fix it soon.

Sorry for the inconvenience this may have caused,


I in fact had this issue and reinstalled comodo 5 times. I tried a new account etc…nothing. Then I realized, Comodo install file MUST be on C: so if you have another partition and put it on D: per se, or have changed the drive letter , something on that order, it is likely that. After putting the install file back on C:, it worked great, simple but almost got me, lol.

If not,

Do a sys restore to known good working order , if not run Ccleaner, if that fails, go to START \RUN \ type in CMD\ in the box type sfc /scannow (exactly as I put and notice the space between sfc and /) and you may likely need the xp disk. This has a good chance to restore your needed files as somethng has gotten deleted or corrupt. I do suggest uninstalling Comodo first, run ccleaner, and even a simple diskclean utility before sfc. Make sure you are virus and spyware free, very important.

Please think what you may have changed with partitions, setup file moved etc…as mentioned first.

Hope this helps,


Hi Paul,

If so, we have a bug there. We need to check this.

Thx for the feedback,

Hi Egemen, yes this in fact did happen. But there are other programs that do this as well as the install path is written to you active partition and when the install is on another active or non-active\different path, it can’t find the proper files. I have had this situation with many programs so I don’t feel it’s just a Comodo bug and in fact makes sense. The activation would be looking to the correct path for activation but if on another partition , it will not find the files needed for activation. No, exe. With security softwares especially this is an issue but not unwarranted either.

I hope this helps you a bit and if you need any more info on what happened, I can try to reproduce it, no problem whatsoever. :slight_smile:



Hi Paul,

Thank you very much. We will try to reproduce the behavior and see what is happening.


You are very welcome. Just for detail sake…I have two hard drives, one holds the OS , one is a backup. I had saved Comodo.exe to the backup drive as I wiped the system clean. I reinstalled Windows, etc…when I installed Comodo from the back up drive, it installed fine but could not activate. As stated, 5 times (not downloaded) but reinstalled I should correct from my last post , but in fact did downloaded “once” again and got a new key thinking it was that. Neither key would work. Finally after reinstalling so many times, 5 or so, I thought about it and moved my setup file back to C: from the E: backup drive and reinstalled, the activation key did in fact work then.
I run XP home on this pc that it happened on, HP OEM version. Pavillion 512 W. 384 Ram, 1.3 ghz intel celeron. 2 hard drives, one maxtor 30 gig backup drive, one WD 80 gig OS drive. Two dvd burner\readers.

Hope this helps some.



P.S. Sorry for leaving you out of the MEATBALL polls. I am still getting used to who’s on here and who’s not.

New Beta same problem!
This was the seventh and the last time i installed this application!

Ok, another info:
I installed the last beta on another pc with windows 2000 prof.
The same error ocurred during activation. So it’s not an error of Windows XP SP2!

What do you logs show? Please try to paste us your CPF logs so that we can understand what CPF is blocking.


Installed Comodo again on Windows XP Prof. SP2.
After startup: gave permission to several programs: antivir, google desktop, Firefox,Opera
Had to turn off network monitor because of rule 4 which blocked any program (Firefox/Opera/Antivir update/Google Desktop) to access internet via my router (BLOCK and LOG IP IN or OUT FROM IP [any] to IP [any] WHERE IPPROTO IS ANY)
Then set “computer security level” on “allow all”, cleared the cpf-logs and tried to activate my license: got the same error and no message in cpf-log!

Hmm. This means CPF is not blocking anything. Do you receive license expired error? Or what error do you see?

Always the same error:

An error has occurred. Error -2146697211: Unknown error, please contact support.

Comicfan2000, I think you may have hit on what the problem is. I, too, have had this same problem on one of my systems. I have 4 systems on my home office network, 2 laptops and 2 desktops. All except my main desktop have the OS (Windows XP Pro SP2) installed on the C: drive. My main desktop has the OS installed on the H: drive. This is an older system so my C: drive contains an installation of Windows 98 Second Edition.

I have CPF installed on all 4 systems and 3 of the systems activated just fine. Want to guess which one is having activation problems… (:CLP) Yup, the main desktop with the OS on H:. Having read your posts, this all now makes sense. It drove me nuts trying to figure out why the main system was the only one that failed activation. I hope that the programmers can find a fix for this because changing the system drive on my main system would require a massive redo of my system, which I really don’t want to go through!

BTW, the 3 working systems have the latest release version of CPF where I just upgraded to the latest beta on my main system in the hopes of fixing this problem.

I guess I’ll just have to wait for the programmers to fix it unless someone out there has any ideas for a workaround.



if you can get enough information you could try using junction points/reparse points … thats a windows version for the linux symlink… don’t know if that could work but it would be interesting to try…

you would be creating a folder that directly points to another diferent folder… if it works with diffent drives it could mean that you can create something like:

c:\comodo\ that points to h:\etc.etc.etc…

on second though that could be too much of work

Resolved my problem!!! COMODO-Firewall activated!

It was the HOSTS-file. Found several “COMODO”-entries in this file. I think this could be entries from “Spybot Search&Destroy”. After commenting out these lines with “#”, activation works like a charm.