A twist on the 'Update failed. Antivirus engine not initialized.'

As you can see from the attached screenshot, everything looks fine (SYSTEM STATUS IS POSITIVE).
But the manual update of the virus database failed, and the Antivirus engine is not even functional!
The CIS version is 3.13.126709.581


Any ideas?
Roy Jensen

What AV database does it say there is installed? When started this to occur? What does running Diagnostics say? Can it fix it? Does rebooting the computer help?

I discovered this last week when it wouldn’t update the engine from 3.5.???. Following another post, I manually replaced cfpupdat.exe with a newer version. The update worked, but did not update the virusscanner database. It is stuck on 14 January.

Diagnostics does not find any problems.

Rebooting doesn’t solve the problem.

Another post commented about replacing bases.cav with the version in the repair directory in safe mode. I did this, but it didn’t solve the problem.

Just now, I replaced bases.cav in the repair directory with one from another computer (dated 27 January 2010). I deleted bases.cav in the scanner directory and ran the diagnostics. Wow! an error! And diagnostics replaced it with the 27 January file. It seems to be functioning, but I won’t know for sure until a new database is released by Comodo.

Roy Jensen

The current database is a 3740. When it doesn’t update the AV I suggest you do the clean installation of CIS. You cannot export your configuration from 3.5 to 3.14 due to changes under the hood. Today 3.14 was released

Get v3.14 in COMODO Internet Security 3.14.129887.586 released.

To be on the safe side of things you could use this clean up tool after the reboot after uninstalling.

I’ve turned on my computer today after updating yesterday.

Checked version and Database version was 0. Checked the files and yet again bases.cav was 8 bytes.

Copied across files from laptop which is OK and restarted CIS. Diagnostic check says no problem, yet when I try to update AV it says “Update Failed! Antivirus isn’t initialised”.

A system restart fixed it but this is the third time I’ve noticed bases.cav being at 8 bytes https://forums.comodo.com/antivirus-bugs/scheduled-av-crash-t50780.0.html

What’s more worrying that CIS being this flaky is that if I hadn’t checked I wouldn’t have known that I was so unprotected!

Why isn’t there any code to check if a valid database is installed and notify the user if it isn’t?


I’d manually check that under services the “Comodo Internet Security Helper Service” is in the “Started” state.

I’ve got pretty much the same issue. Beginning to lose faith in CIS: what’s the point in an app that has to be uninstalled and reinstalled every update?

Here is my solution to the problem. I have come to that resolution after many hours of frustration and research.

  1. Uninstall CIS completely
  2. Re-install WITHOUT the Antivirus component
  3. Install another free tool like AVG, Avira or other.

Comodo D+ and Firewall are top notch and are well worth having. I don’t think there are better products out there, certainly not in the freeware world, but the AV, especially in the updating process, has yet to reach the same standard.

Good news is that in v4, the updating process seems to have improved greatly.


I uninstalled and installed Comodo on my system to resolve this. But, it did not help.

I tried every other thing I could think of… :stuck_out_tongue: but no solution.

So, the only thing that worked for me was… I restored my windows (Windows 7) to an earlier point. Then when I tried to update the database… It updated as if I have installed Comodo Anti-Virus for the first time on my system. That is, it downloaded the full CAV file. So, I think the issue was that the Anti - Virus database was corrupted and the Anti - Virus Engine was unable to read it.


CSI 5.0.163652.1142

Same problem as above, just stopped working this morning. Funy thing is comodo claimed to have fied this bug 4 yeas ago https://support.comodo.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=307

Is the problem still happening Azuse05?

In that case follow [url=https://forums.comodo.com/anti_virus_faq/where_can_i_download_the_latest_full_av_database-t47164.0.html[Where can i download the latest full AV database?[/url] and try updating again.

I’ve just uninstalled Comodo Anti-virus AGAIN. I’m fed up with it always messing up after few weeks of using it from a fresh install ''Antivirus engine not initialized ‘’ (Yes I’ve tried done all the tweaks update where possible that were suggested in the forums) Just going to stick to using the Comodo FIREWALL with another anti-virus. The firewall is the best piece of kit I’ve used so far just wish the AV didn’t f >:-D©k up so much…

This doesn’t happen to the majority of the users. Perhaps you could submit a bug report as outlined here:

This is likely the only way the developers can help solve your issue.

You know what Comodo… I have to say I’m really upset here. My antivirus program was compromised with this bug for probably a week before I noticed that things weren’t updating correctly… and that my “antivirus engine was not initialized”

What would have happened if I had gotten a virus in this time? How can Comodo just sit there willy nilly while parts of it are clearly corrupted?

I’m really disappointed Comodo. I trust you guys with the safety of my PC and this isn’t the first time this has happened to me. I don’t see how anyone can trust their system to a security suite that has an antivirus engine that can crash itself and give no notification or message to the user about it.

I’m just really disappointed, and I’m reassessing whether or not Comodo is my security suite of choice. MSE is looking really good right now.