A dissappointment with Comodo

I could not find an area to post this so if the mods think it needs to go to a different place, feel free to move it and let me know. I have had comodo for a couple of years and have been very satisfied. I signed up for 2 years and that runs till mid 2014. I contacted geek buddy a couple of weeks ago, and they tried to tell me I only had malware help, and nothing else. I told him I have used other services at least 3 times this year. They then talked me into purchasing PC Tune up even though I tried to tell them I had it with 2 year contract, and sent them a copy of my receipt, and highlighted the “PC Tune”. They refunded my money for the PC Tune up, but I am unable to use this. I am not sure if I need to use this thru geek buddy or not. It seems to me that they have a new price structure, and that is OK, everyone has price increased and things like that. My problem is that I have a an paid order receipt, and that should stay in effect until my expiration date, but I can’t get anyone there to tell me why they are still trying to charge me, when I have a contract good for another year. I am finding this to be frustrating, especially since no one from the support people I am emailing are telling me why this is going on. I even have an ID , and password for trust connect on my paid order, and that won’t connect either, it says I don’t have it and it wants me to pay some money for it. I hope there is someone out there in Comodo Land that can tell me why my paid order confirmation for another year means nothing, to the people I have talked to so far…

I’ve split this into its own topic, as I believe it will get better visibility that way.

I am a volunteer Moderator for these forums, and am not very knowledgeable about the details about what comes with a paid version of CIS. By the way, are you using CIS Pro or CIS Complete? I’m not sure if the coverage for GeekBuddy are different for the two, but it’s probably worth noting.

Hopefully someone who is more knowledgeable about this will comment soon, but if you don’t get a response within 24 hours please feel free to bump this post.

Thank you.

I have a similar problem My CIS plus GeekBuddy subscription expires 6/14.

I’ve been using Comodo since 2008. My CIS/GeekBuddy subscription is till 6/2014.

GeekBuddy hasn’t worked for almost three months.

I’ve been getting the run around for almost 3 months.

Runtime Error Program C:prog files comodo geekbuddy \unit.exe This application has requested the Runtime to terminate it in an unusual way. Please contact the application’s support team for more information.

Then the screen to write the problem message disappears.

Rapier. Please don’t cross post and continue in your own topic. I have replied in the topic and hopefully we can get a better understanding of your problem and whether it is a bug or not.

I had to delete my latest update of Comodo using “Save Mode” to start my laptop and have not been able to delete “cavshell.dll” or to regain access to the web
Comodo is way above average, but when I called the Geek’s phone included in my last Comodo update, a young fellow I talked to over the phone did not know much about troubleshooting software. He immediately blamed Windows for the problem I had. [Experienced personnel asks for the overall situation before (transferring blame) giving solutions.]