3D Creative Digitizing Program Crashes on file save

Today I have had to uninstall Comodo CIS 3.9 (Defense & Firewall) off two laptops (family and friend).
Both have Windows XP Home. One uses Avast AV and other Comodo AV.

They use Embroidery Sewing Machine software for creating and editing embroidery designs - 3D Creative Suite - and there is one module that has the problem. The program uses an Aladdin Knowledge Systems dongle for software protection. The dll file that is reported as having the problem is a Lead Technologies dll that the system must use or it won’t open at all.

The digitizing module allows the creation of a ‘can’ file which is a type of graphic / stitch design file that contains the instructions for creating the actual ‘vp3’ embroidery file. The ‘vp3’ file save works, but the design creation ‘can’ file crashes the digitizing module every time the file is saved. It will save a ‘0’ empty file, but as soon as any graphic data is entered the problem occurs.

Before identifying Comodo as the culprit I completely uninstalled / reinstalled the program, ‘repaired’ Windows, checked file permissions, and added all the exe and dll files as ‘safe’ in Comodo. This has been an on-going problem since at least the beginning of April, but I was able to overcome it by replacing the ltfil12n.dll by the original as I assumed it must have been corrupted. This time nothing worked and as a last resort I uninstalled Comodo and bingo! everything works as it should.

This is the entry from the Event Viewer.

Event Type: Error
Event Source: Application Error
Event Category: None
Event ID: 1000
Date: 1/07/2009
Time: 12:05:55 p.m.
User: N/A
Computer: FUSCHIA
Faulting application 3ddigitizing.exe, version, faulting module ltfil12n.dll, version, fault address 0x0000c5d5.

For more information, see Help and Support Center at Microsoft Support.
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 46 61 69 6c ion Fail
0010: 75 72 65 20 20 33 64 64 ure 3dd
0018: 69 67 69 74 69 7a 69 6e igitizin
0020: 67 2e 65 78 65 20 37 2e g.exe 7.
0028: 30 2e 30 2e 30 20 69 6e 0.0.0 in
0030: 20 6c 74 66 69 6c 31 32 ltfil12
0038: 6e 2e 64 6c 6c 20 31 32 n.dll 12
0040: 2e 30 2e 30 2e 31 31 20 .0.0.11
0048: 61 74 20 6f 66 66 73 65 at offse
0050: 74 20 30 30 30 30 63 35 t 0000c5
0058: 64 35 0d 0a d5…

I have attached a copy of the DrWatson error report for April 09

I always recommend Comodo especially to people who are not long time users who really need reliable worry-free protection so hopefully this is not going to be a show-stopper for them. :wink:

[attachment deleted by admin]

May be it is something that can be worked around. But to know that I need to see the Defense + logs. I know it’s a pain up the bum to ask. They can be found under Defense+ → Common Tasks → View Defense+ events.

Hi Eric,

I hope it is alright, but I will have to get one of the laptops back over the weekend and re-install Comodo to generate the error and get the log.

They both had deadlines to meet for their digitizing classes and I just had to get the machines working so they could finish their assignment.

I will post as soon as I can do this.


Can you go through this post? May be it has something to do with buffer protection.


Hi Eric,

Here is the Defense+ log.

I re-installed Comodo on my friend’s laptop and made sure that 3DEmbroidery.exe was entered as a ‘trusted application’ in the firewall and a ‘safe’ file in Defense+, but no luck until I uninstalled Comodo again.

I had done this with each of the various individual exe files that make up the 3D Creative Suite modules before the trouble started. Unfortuntely, this is one program that installs in its own 3DEmbroidery folder and not under ‘Program Files’. It also keeps the data folders ‘MyDesigns’, MyPictures etc., in that same folder application, so it isn’t safe to select the whole folder as an exclusion.

Possibly it may be the buffer protection problem mentioned in the above post. If you don’t have any other theories, I will get my friend’s laptop back during the week and try re-installing with the buffer overflow protection excluded for each exe file.

[attachment deleted by admin]

This is a memory sharing issue, simple to resolve.

Select Defense+ -->Advanced → Computer Security Policy.
Scroll down to Comodo Internet Security, select Edit → Protection Settings.
Interprocess memory Access (Active Yes) select Modify → Add -->Now use Running Processes or Browse to point to the concerned file(s) . In your case 3DDigitizing.exe and 3DEmbroidery.exe.
Then just “Apply” to each window as you exit.

Hi EricJH,

Well we are on the right track in that it is Defense+. I have left the latest version of the firewall without Defense+ on my friend’s laptop as I didn’t want to leave her with the Windows Firewall, and that allows her to work OK.

After following the Interprocess Memory Accesses instructions, I tried again. From the logs attached you will see that there is no longer any mention of the 3D exe files, only the DrWatson ones from when the program crashed.

The second log was created when I added every single suite exe file into ‘My Own Safe Files’ as well as in the Interprocess memory Access area. I also added to both areas the dll file that MS Event viewer lists when it crashes. …and it still crashes as soon as you enter some drawing objects into the Digitizing module and try and save the design outline ‘can’ file.

I disabled her wireless and in the Defense+ settings → Monitor Settings unchecked the ‘Interprocess Memory Access’ option. This didn’t help either, which would suggest a problem elsewhere.

I had thought it might be the device driver for the Aladdin Software Security dongle (Hasp), but this would then affect anyone else who uses software with this type of software protection device and is using Comodo which I think would be quite a large market Cloud Protection & Licensing Solutions | Thales

Anyway, I hope this info helps in finding a new solution.

[attachment deleted by admin]

Moved to the bug boards so the devs can take a look.

Now Comodo Firewall alone is causing the same problem. I have had to uninstall Comodo completely and replace it with ZoneAlarm so the two ladies can continue with their digitizing.