3.9 (508) - virus defs won't update

Its been reported the updater sticks a long time at 30%; as from downloading 5 MB to 30 MB. I can imagine when the update process is slow it may be too long for people to wait.

On another note there is an emergency update for CIS with version number 509:

I had a similar problem until I edited the registry and changed the UpdatePath to equal av/updates39 in all of the Comodo settings. Av updates started working again then.

thanks for the hints. I’ve checked my registry and it is as described already i.e. set to av/updates39

the problem continues…

Make sure that you have check all occurrences of the UpdatePath. My system had several, mainly due to all of the beta versions. I had to change them all.

I’ve been through everything I can find - no joy.

I removed 508 completely - checking for all traces in the registry making sure all CIS references were gone, then installed 509. Same problem. It just won’t update - which is a sub-optimal situation for an AV! If I can’t solve this I’m going to have to remove the AV component and go back to the firewall + avast.

Ha Ha!!! This was the answer… for me at least. :slight_smile:

Following all the tips in this thread, I’m still not able to update, stops at 30 %. I’m reluctant to go back to Avira but I guess I have to unless someone solves this problem soon.

I had a simular issue. Opening Internet Explorer first then doing the update (as a one off) worked for me, eventually. Also check for updates in Miscellaneous as .509 is now out!


Nope, didn’t work, first this:


then this:


Never getting past 30%.

Did CIS detect your network after you rebooted?

Ended up reinstalling CIS from scratch, all is good now. :slight_smile:

3.9 (509) don’t want to update more.
the AV database number is 1154.
The problem is there from three days ago.
I install 508, then update to 509.

In an effort to resolve the problem of CIS 509 AV updates not working, can somebody that currently has AV updates working under 509 please supply me with the value of Version for the following 2 paths…

HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations\0
HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations\1


0 = 0x03016295 (50422421)

1 = 0x03016295 (50422421)

Yep, in all my 4 configs is the same version

[attachment deleted by admin]

And you guys have AV updates working under 509? If so, then this isn’t the problem (unfortunately).

One thing that I have confirmed is that when CIS says check your internet connection (implying that it’s not working), there have been communications between your system & Comodo’s servers. Thus the message generated by CIS isn’t correct in this implication. Something else is wrong.

Mine is working, I just update to 1170 half an hour ago.
And I have update CIS from beta to beta till 509, is not a clean install of 509.

I don’t know if this is relevant, but a while back there was problems updating Avira. In that case users had their host files hacked and were being redirected away from the real update servers.

I don’t have HOSTS file hacked.
CIS 509 stop updating from may 14.

Is possible to create a “CIS Registry Cleaner” for this problem? (erase ALL CIS orphan registry entries)
KAV has one.
NOD32 has one.
This can solve the f*** update problem for users that installed Beta/RC before 3.9 final.

I also check the HOSTS (which I don’t use) & just contains the default - localhost entry.

I believe CIS updates were halted for CIS 3.9 RC’s on purpose by Comodo after some users experienced problems with the AV updates. For me, they’ve never worked since.

I don’t believe so. Well, not in my case anyway. I’ve not run CRC on my system that has this issue.

Looking at CAP (Packet Sniffer Captures) that I’ve generated during an AV update attempts, it seems very confusing. There are 404’s, 302’s (Moved Temporarily) & all sorts of responses as it attempts to find & download the CAV files. I don’t think these are a problem, it’s just the way Comodo distribute the AV updates for different geographical locations. It’s just very confusing to follow. But, it seems to encounter a problem downloading/finding BASE_UPD_END_USER_v1155.cav (ie. where it stops)… which is odd, since CIS seems to find & download 1158 to 1164 without issue. My network connection might be just too slow… but, I’m not sure. Still looking.