3.8.65951.477 prevents many applications from running

I upgraded to 3.8.65951.477 yesterday. After rebooting, I could not run many of my normal applications (Firefox, Open Office, SeaMonkey, Quicken, AVG Antivirus). Microsoft applications such as Internet Explorer and WordPad run okay. Terminating the Comodo Firewall did not affect this problem.

I am using Vista Ultimate 64-bit with Service Pack 1 and AVG Free Antivirus.

I see that others have reported problems with 3.8.65951.477, but none of the others seem to have the symptoms that I encountered.

I will try to roll back to an earlier version, as others have reported that this solves their problems.

Try disabling your AV first. There seems to be some conflict (with this release) and [some] other AV software.

Try rebooting. I saw the same thing with updating CIS on XP. Didn’t deal with it and booted Win 7 beta and there it happened as well. Rebooted and it went. Rebooted later to see what happened and it did not come back for now.

it seems to have something to do with Ad-aware SE if you have it. To fix it either uninstall one or the other and you should be fine. I had the same problem and then uninstalled Ad-aware and installed CIS again and everything worked fine.

I have rebooted several times, and the problem persists. I will check on Ad-aware SE (I don’t know if I have it - the problem is on Vista 64-bit, and I am currently running Vista 32-bit, which I dual-boot and use mostly - until now - for games that won’t run under 64-bit).

I appreciate all of your suggestions!

I checked out other posts on 3.8.65951.477 and found COMODO Internet Security 3.8.65951.477 Released. It says that the internet update is a 2-part process, so I did a manual update, hoping that it would find a missing second part. It found something to update, but after the update finished, I still could not run my usual applications.

As a last resort, I uninstalled Comodo firewall and downloaded a new version of 3.8.65951.477 from http://download.comodo.com/cis/download/setups/CIS_Setup_3.8.65951.477_XP_Vista_x64.exe. I installed the fresh version of 3.8.65951.477, and everything seems to be back to normal - at least my applications now run!

Barring further problems, uninstalling and reinstalling seems to have fixed my problems. I want to thank everybody who stopped by to help out!

Unfortunately, my success lasted only until I rebooted. I gave up and uninstalled Comodo firewall.

I guess I will have to wait for a new release. Sigh…

okay i suggest one of two things

Uninstall ad-aware and see if that fixes things with CIS or completely disable the Defense+ feature in CIS and restart your computer while still keeping ad-ware. This is what helped me.

Have you tried doing anything with changes in Ad-aware yet?

same problem here. I can’t tell you what version of CIS because i had to uninstall it to get online. IE, Firefox, etc would not open and many of my start up items would not load.

I tried a restore to before the Network Service Commodo update at 8:59pm last night. Apparently something in the update hosed everything. So I tried to update Commodo again, thinking you had a patch to fix the problem. It updated, but didn’t fix the problem.

Went round and round with failed system restores to get my x64 vista system pre-commodo update and was unsuccessful. Finally let windows boot repair run for quite a while to get back to windows and uninstalled commodo and rebooted. viola all my startup items are back and i could open IE.

I was afraid I was going to have to do a system recovery and lose everything, but luckily with previous issues with Commodo and remembering that it updated last night, I uninstalled it.

Can you tell me what happened?? Right now I’m running no AV.

System restore said Commodo Network Service updated last night. That’s about all I can tell you.

appreciate it.

just wanted to add that i installed the latest AV only > rebooted > same problem. had to uninstall comodo again.

i do have adaware installed but no services are running and i use it as needed (rarely)

are you saying I have to totally uninstall adaware? the version I have just says adaware.exe version

aawservice is not running and isn’t even listed in windows services as I run it manually.

for now I loaded an eset AV trial with no problems. I’ll check back to see if you have any answers on this comodo issue. to hose my OS is pretty bad lol

Download and get 3.5 and disable updates until you see 3.9 or higher. That’s what i did and everything is working again as it should be.

i just uninstalled adaware - installed 3.8 CIS av and firewall and everything is working fine. i don’t use adaware enough to worry about it.

what’s weird though - i left eset running and it’s in task mgr but i don’t see it on my taskbar. i see comodo running.

i’ll open eset and see how to prevent it from loading on start up.


There is a serious problem with this update.

You cannot run anything outside C:\Program Files\ (the 64bit program files folder).

Moving to use another firewall product, bye.

I have the same problem here. I use avast! from Alwil and it does not work.
Windows is starting, but many programs does not start at system startup. For example the Yahoo Widget Engine does not start, Spybot Search and Destroy does not start, also my antivirus program does not start.
When I start the Task Manager I only see my own processes, not all tasks running (this was different before). I always have to press the button below to see all processes running.

And I can not start any program. Winamp, avast!, Internet Explorer, Firefox, Thunderbird … nothing works!
That is really pooty … this version is really like a pre-pre-pre alpha! It is full of bugs. I had another version a few month ago (take a look here: http://www.karrock.de/daf/2008/11/problem-with-comodo-firewall-update-under-vista/).

I have the feeling that Comodo does not test the version with vista (64bit). That is really pitty because the firewall is really good and smart.
I hope there come fast help, because the only actual solution is to deinstall the firewall.

The thing with Ad-Aware I have not tested yet.

Another problem is, that bug reports can not be send via the firewall software. I had a bug that cfp.exe crashed and the dump and report can not send. Very strange.

---- edit
ARGH! Fix your buggy forum software. Everytime I write an apostroph (the upper one next to the “?”: http://www.eteach-as.de/pics/taste_sonderzeichen.jpg) my post will be cut off at this position. …
=> Your software can not handle special characters (like german szet for example!)

I have the same problem. Below is a full bug report as requested, plus a Comodo Firewall Pro Configuration Report in hopes that it will be of some use to the developers. The only solution, after hours of trying to figure out what was going on, was to uninstall Comodo. I may try to install a prior version, but for now am running Windows Firewall :o

CPU (32 bit or 64 bit)

AMD Turion 64 X2 Mobile Technology TL-64 2.20 GHx (64 bit)

Operating System information (including Service Pack Version)

Windows Vista Ultimate, Service Pack 1

Actively-running security and utility applications (Optional if you post a Comodo Firewall Pro Configuration Report)

Attached report as JMB0687 CIS_Report.txt. Note that Comodo is not currently running as I had to uninstall it to get operational again. I am currently running Avast and Windows Firewall.

Specific symptoms of the bug, and steps you can take to reproduce it (step by step).

After Comodo update, vast majority of applications will not open. This includes Avast, MS Word, IE, Firefox, Thunderbird, Streets and Trips, iTunes, Notepad, etc. What worked was Windows Explorer, All programs in Control Panel (at least those I tried), all programs run at the DOS prompt, all programs run using the Run command. Two noteable exceptions, both Windows Installer and System Restore would not work, making it impossible to uninstall any programs or fail back to an earlier state.

Specific steps you have taken to try to resolve it.

Stopped a bunch of services, killed a bunch of processes, attempted to uninstall a bunch of programs (with no luck since Windows Installer failed), attempted 3 Restores to days prior to the problem (again, with no luck since System Restore failed). Then had the thought that it might be related to Comodo. Fortunately, the Comodo uninstaller in the Comodo menu group worked. Restarted the computer and everything worked again. Attempted to reinstall Comodo and the install failed at some unknown point. It looked like it was working until the very end when it suddenly said that the rollback completed successfully.

Brief description of your Defense+ and Firewall+ mode (Custom, Train with safe) plus mention if you modified any setting in ADVANCED section of D+ and F+ (Optional if you post a Comodo Firewall Pro Configuration Report)

Attached report as JMB0687 CIS_Report.txt.

If you pc reboots or you have a BSOD post in BSODs: Please add your minidump files here

No reboot or crash.

Report if you are using an Administrator account Or a Limited User account. Vista users please Report if you have UAC Disabled or Enabled (Optional if you post a Comodo Firewall Pro Configuration Report)

Using an Administrator account, have UAC Disabled

[attachment deleted by admin]

I have also tested the issue with deinstalling Lavasofts Ad-Aware and this works!

I deinstalled Comodo Firewall completely. This does not work, after a reboot I deinstalled Ad Aware and than I reboot and reinstall CF. Now it works!

I had this same issue. After downloading the latest updates to the firewall, 90% of programs would not start (office, firefox, etc). Fortunately, windows restore worked after I went back a couple of days.

I’m running 64 bit Windows Vista Ultimate.

Please fix this very frustrating bug.