beta and BOINC/SETI@Home

Problem: Comodo Firewall Pro beta is blocking BOINC/SETI@Home from running.

Solution: Turning off Image Execution Control

Sorry if this has been posted before, but a search turned up nothing on the subject.

I run SETI@Home (BOINC) as my screensaver. However, CFP is blocking it from running AT ALL and the only way I have found to correct this behavior is to turn off Image Execution Control. Personally, I like IEC on, but this is hindering my screen saver. I’ve added all of the necessary files to Defense+ and Firewall policies, but it is still being blocked.

So… does anyone know of a solution to this problem other than disabling Image Execution Control?

Thanks in advance,