D+ -> My Trusted Software Vendors

I upgraded to with a clean install and now i cant add anything to the my trusted software vendors. Everything i try it says its not a signed executable. I went back to and it works fine. I upgraded through the updater and now the not signed message comes up again.

Any Ideas?

cfp does not recognize digital signature.
McAfee VirusScan Enterprise 8.5i
Adobe Acrobat 8
Spybot - Search & Destroy
MS Office 2007 (Word, Outlook)
and many more
D+ Settings Train with Safe Mode

WinXP SP 2 all Patches
Windows Server 2003 SP 2 all Patches

Went back to v3.0.21.329 and all working fine.

Posted by: Ronnie1

I upgraded to with a clean install and now i cant add anything to the my trusted software vendors. Everything i try it says its not a signed executable.

I can confirm this. Previous CFP3 builds allowed you to manually add Trusted Vendors, but the feature appears to be broken in build This build doesn’t seem to be able to read / recognize Certificates.

I can also confirm this. I’ll let egemen know…


Please give more details: which signature, detailed steps to reproduce issue, actual results, expected results…

Thank You!

I noticed this as well. Most of the vendors I could add in previous versions don’t work anymore. Here is by heart and at random:
CCleaner Pirisoft
Powerarchiver Conexware
Real Player Real networks
Spybot Safer networking
A squared Free Emsi Software
Spywareblaster Javacool software
Nero Nero AG
Quick Time Apple Inc
Isobuster Smart Projects
Adobe PDF Adobe
Hitman Pro Surf Right

Here are the only ones that I could add:
Trojan Hunter Mischel Internet computing
PDF xChange viewer Tracker Software

That is my list for as far as I could retrieve from memory.

can’t confirm. i did clean 3.0.22 install but then imported 3.0.21 rules; CCcleaner, VSO and Avast added after import.

[attachment deleted by admin]

Can you add anything manually with the add button? I tried to add avast, CCleaner, Adobe and others but it didn"t recognize the signature.

[attachment deleted by admin]

my poor english :frowning: Avast, CCleaner (and more) was added manualy (1st from running processes, 2nd with add button) - that was done after i did import 3.0.21 rules where “trusted apps” was only Comodo+M$

I will confirm … any attempt to modify the Trusted Vendors results in a crash to desktop and the timing of the crash is variable from 1 sec to 20 sec from attempting to browse to an executable.


Reinstalled 349 from the full 349 installer and Comodo doesn’t crash any more but as with the others I can’t add any trusted vendors.

At least now I can set a custom defense policy for a program … in my upgraded 349 version there was a crash.


I have got same problem with ver


Same here. I can’t add any executables to trusted software vendors. Same message as everyone else, “The file does not seem to be a valid signed executable.”


will there be a bugfix anytime soon? This is a pain especially with AV Software … each time the Anti Virus updates, it must be re-classified as trusted application … would be so much easier if recognizing digital signatures actually worked.


No your wrong about that. Make your av updater an “updater/installer” and your problem will be gone. What AV are you using?