Miniport installation problem causes firewall to fail to start

Ran an uninstall and clean install after first trying out the update. Some of the failed installations where the firewall does not work can be related to failure to properly install the miniports before reboot. The restart message occurs before installation of the miniports is complete. In .295 and earlier, there would be an “installing new hardware” after the reboot, and when done, booting again would solve at least my firewall problem. For .304, the restart appears to show up earlier, and after boot the miniports do not complete installation, showing up with the dreaded yellow triangles-like quiet installation. Fix would be to wait until installation is complete before telling user to reboot-some of previous failed installations may just be timing problems. I finally got .304 firewall to work by going to device manager and watching the miniport installation, and not rebooting until it was complete. This should not be a problem with updates at this point. Attached is an example of what it should look like if you allow the installation to complete and then show hidden devices in device manager.

  1. 32 bit
  2. Vista Ultimate
  3. Avast!
  4. After clean install and boot, summary shows “firewall is not functioning properly” and diagnostics are ineffective, say unable to fix some problems
  5. Tried reboot and a couple of clean installations. Reboot had solved the problem for previous versions 14-16; did not for this one. Looked at device manager, saw that miniports 2 and 20 showed bad installations. Previous version had shown the “installing new hardware” Vista message; did not. Did another removal/reinstallation. Observed that installation was incomplete when “reboot” message came up. Went to Device Manager and discovered that miniport installation was still underway, even though urged by CFP3 to reboot. Waited for installation completion before reboot, and firewall came up normally.
  6. Firewall broken, D+ in default clean PC Mode. Settings at default.
  7. No reboot or BSOD.

[attachment deleted by admin]

If I undertand correctly the final screen of cfp installer is enabled before the miniports installation is complete.
Thus leaving the reboot checkbox checked and clicking finish will break CFP installation.

Is that so?

Yes; that is what I observed. I have lots of miniports, as the picture shows, so maybe others finish in time. But the reboot should not be called for until installation has finished. And I did find that the miniport installation had failed by looking at Device Manager. The other thing is that on previous CFP3 versions, the “found new hardware” wizard would appear. Didn’t happen this time, CFP3 switched to quiet installation of the miniports or ??? But they show clearly with disk activity and I can watch the installation continue in Device Manager. And each time I booted when the final screen was enabled, the firewall failed to install. And when I waited and watched until completion, it installed normally. I tried 3-4 removals/reinstalls to try to get a handle on the problem.