3.0.17-.22:Lots of Network Connection Problems (MERGED TOPIC)

I have updated my comodo firewall to, after that I have problems to retrieve ip address through dhcp. Sometimes I have to disable comodo firewall, so that ip address can be successfully retrieved. I have no such problem when I use earlier versions of comodo firewall. Is this a new bug?

This is not a problem for other users, so I am moving your post to the “help for v3” section to provide more visibility and inputs from other users. What is your OS? Are you using a router? What type of internet connection do you have? Do you get any block messages in your log? Try putting a “block and log all” rule at the end of Windows Operating System in firewall/advanced/network security policy and see if you can find out what is being blocked. For DHCP you need to allow UDP traffic between your computer port 68 and the DHCP server port 67.

I am using CFP V.3 on vista. Before an update for comodo, i was using it very well. But after update, I had a connection problem my wireless router. The firewall lets me connect my LAN but doesn’t let me in internet…So I have to disable the firewall.
If someone help me, I will be very very happy because I waste too much time to solve my problem…

I am currently running a wireless connection to Vista Ultimate with no problems, CFP that the version you are using? Does your router actually get an IP from the internet? What router/firmware are you using? What kind of internet connection do you have?-DHCP, PPPOE, fixed IP, ??? Do you show any blocks in your firewall log? Does everytning else in CFP3 seem to be working? What actually happens when you try to connect? Do you get limited access, local access, or nothing? Do you get a LAN IP? = How long ago did you update CFP3? How is your wireless adapter setup? Auto IP and DNS?

My CFP is .I don’t exactly know my LAN’s techniqual details, but it must be a PPPoE connection. Firewall shows no log and I could not find why the firewall blocks my connection. My firmware is Broadcom ADSL Router. It works regularly until I enabled my firewall. But if I open, first my connection turns to limited access, and I try to solve it using vista and I can access my LAN, but no internet connection…

Do you get an IP for your wireless adapter, but no blue dot? Or an internal IP like 169.xx.xx.xx? Trying to isolate how far into the connection mechanism you get before things don’t work. What are your rules under Windows Operating System and your Global Rules? When did you do the update to CFP3, and from what? Usually the default settings work fine for wireless.

I get an IP for my wireless… I have used CFP for a week without any problems, but after the update was done by firewall automaticly-must be four days ago-, the problem accured.

There is something in Global Rules like “Block ICMP In From IP Any Where ICMP Message is ECHO REQUEST”

Your global rule looks like the default, so OK. If you get a real IP on your network for your NIC but no internet, may be a problem with the installation itself-there have been a number of reports of that. Try downloading the full version of and doing a fresh install. Running the installer will do an uninstall for you, and then you will need to reboot and do the installation by running the installer again. After the installation reboot, there will be a popup asking to reformat your settings, and you can select “no” to keep your old settings, or “yes” to use the new format and new default settings. Unless it would set you back a lot, there are enough changes that it is a good idea to select “yes” and allow CFP3 to learn your settings again.

ok I will try… Thank you so much helping me and preventin me from wasting time…:slight_smile:


As a longtime Comodo Firewall user, I’ve grown accustomed to terrific performance and reliability from Comodo’s products. So, you can understand my shock when CFP3.0 made my network/Internet inaccessible today.

CFP worked fine Saturday, and I was able to enjoy unfettered access to the 'Net and network. Sunday, I didn’t use the PC at all…and Monday morning my PC’s Internet/network icon popped up with “limited or no connectivity” on my desktop PC. System Restore to a Friday system checkpoint changed nothing–the “limited connectivity” tag re-appeared. Only when I uninstalled CFP 3, everything returned to normal.

I thought this was a fluke with the desktop’s firwewall; however, the same thing, I’ve found, has happened on my HP notebook. CFP 3.x killed wireless network access…and then kept bugging me to accept an unrecognized IP address/network.

What have you good folks done in that last software update? :cry: And why would access to a network spontaneously go away after the computer wasn’t used for a day?

Thanks for listening. Any info will be much appreciated.


The unrecognized address was probably a self assigned address from your computer when it was unable to get an IP address from your router via DHCP. For DHCP, you need to allow UDP traffic between port 68 or your computer and port 67 of your router. First try rebooting your router. To see if it is just a DHCP problem, you can try using a fixed IP address: Go to Network sharing center/manage network connections (or XP equivalent) and find your wireless adapter. Right click, select properties, find tcp/ip, select properties an there will be a table to fill in. For the fixed IP use your router IP with the last field changed to 10 or something else not used, netmask, gateway address your router address on the LAN. For DNS servers you can use and I have seen a few reports of this, but haven’t verified solutions yet. :frowning:

Thank you, sded, for the workaround. I’ll save a printout of it so that I can set everything correctly once I reinstall CFP 3.x.

It would be great if the good folks at Comodo looked into this odd, spontaneous bug and incorporated a fix ASAP. Less-experienced users out there might mis-diagnose the problem as some sort of hardware failure, because they won’t be able to connect to the Internet without having done or updated anything.


Also, if you haven’t already done it, try rebooting your router.

Also try rebooting your router if you haven’t already done so. And set up a fixed IP for your adapter and see if that helps. You can use and as your DNS servers. To set up a fixed IP, go to network connections, right click on you adapter and select “properties”, find tcp/ip and select properties. Fill in an IP using the address of your adapter with the last digit changed to 10 or some other unused number, netmask, gateway your router IP address, and see if that works.

We are still looking for the solution. Let us know if the workaround fixes it for you. Or if the reinstall does it by itself. :slight_smile:

Thought these had enough in common to merge them and look for common solutions. One other comment-I have noted with the latest version that sometimes the connection icon shows the red X, and says there is no connection, even though the connection is still working fine. I orginally attributed it to the VPN I was using, but removed it and still have the problem. So please let me know if the connection appears to die or not start and is still working. Thanks; Ed.

Okay, I uninstalled CFP 3.x–and then ran CCleaner to remove all leftover hangers-on. I reinstalled a freshly downloaded copy of the latest version from Comodo. Upon the first re-boot, CFP 3.x ran and behaved properly.

I shut down the PC, had lunch, and turned the machine back on. “Limited or no connection” icon was back, as was the request to accept the new IP address.

Whatever was added to the latest Feb. 13th update is the cause of this problem, for everything on two seperate PCs was working like a Swiss watch up until this latest release arrived. On the laptop, the auto-update killed off an already discussed DLL (which made launching/uninstalling the program impossible). When that little hiccup was fixed with a “transplant,” it worked for a while–and then it simply killed off wireless/wired networking.

My desktop didn’t share in the DLL “vanishing act,” but its networking went adios shortly thereafter.

I’m giving the workaround a shot and will comment on this board whether or not it worked. In the meantime, can Comodo’s ■■■■■ staff give this latest version’s updated code a good re-examination? :THNK

Okay, I can report that the workaround has worked on my wired, desktop LAN connection. :BNC Hopefully, I can get the desktop fired-up and running as well using this same solution.

Could you all with this problem let us know what OS you are using? We are trying to see if this is just a Vista problem, or affects XP too.