on a comp with 2 ip's bound to one nic

As the subject says 273 and 276 don’t seem to want to play well on a comp with 2 static ip’s bound to one nic. 268 works great so that’s what i’m using for now. If i upgrade or do a clean install to either 273 or 276 no inbound connections are being filtered. It will detect outgoing connections and prompt for a rule but anything inbound sails right on in. If I add a block rule in the global rules it will catch inbound there and block it. But once beyond global rules it ignores all application rules. The machine in question is running XP SP2 with all the latest updates installed. I’m running 276 successfully on this my main box with XP SP2 without any problems at all. I’ve uninstalled and gone through the manual remove process to be sure there was no old rules hanging about mucking things up. Also that box is my server. It has DNS, Web, FTP, Mail, Remote Admin and a few other things running and listening on various ports. When I install 268 and reboot and check View Active Connections there all there listening on there various ports. With either an upgrade or clean install to 276 when I check View Active Connections there is nothing there. If I then stop and restart the service in question it will show up but it ignores any inbound rules I make for the application. The 2 networks bound to the nic are a local 198.162.. network and a static 24.79.. network. I’ve tried every possible configuration I can think off to get it working. I’ve uninstalled and reinstalled at least 20 times. Anyone have any ideas? If not I hope Comodo is working on an update and it’ll work gain. :slight_smile:

Just a follow up. I solved my problem by installing a second nic in that machine. With the 192.168.. network bound to the second nic everything works fine.
As a FYI. I uninstalled and wiped all traces from my registry and folders. I then rebooted and ran a registry cleaner and then removed the local network from the nic. I then rebooted again and installed 276. Upon rebooting everything was fine. It was catching incoming traffic and properly identified all my servers listening on there various ports. I rebooted again and re-bound the local network to the nic. As soon as I did so it started ignoring incoming application level traffic again. I removed the local network binding and rebooted and again it was fine. I then shut down installed a second nic and now it’s all good. But something in 273 and 276 isn’t working the way it was in 268. Using 268 I could have both networks bound to the same nic and everything was fine. Using 273 onwards and more than 1 network bound to the nic and i’m losing all incoming traffic filtering at the application level. I hope the developers see this as it seems to be a bug in the later versions. If a mod sees this maybe they could pass the information along to the appropriate persons. Thx! :slight_smile: