100% disk load due to CIS Helper Service slows down PC

First of all, it this question has been posted before sorry about that.
I tried searching the forums and the configuration FAQs but could not find anything specific on this problem.

I’m running CIS Premium V8.2.0.4508
Windows 8.1 Pro 64 bit / Intel i5-4210H [at]2.9GHz / 4GB RAM MSI Gaming series laptop

System was running fine and quite quick. I like the COMODO products but with the latest update my systems slowed down a lot.
Checking the Task manger I found my systems has a constant 99-100% disk load and the main cause: COMODO Internet Security - COMODO Internet Security Helper Service
It goes over 10MB/Sec at times stressing you my system.

What can I do to fix this?

*Edit: Just to add something. When I shutdown COMODO the disk load drops to normal values below 50% even when running all kinds of software at the same time.

Do you have other security programs installed that run in the background alongside CIS? What process are you shutting down? Can you think of processes cmdagent.exe may be responding to like f.e. an indexer?

First of all, thank you for your reply.

  • I did not have this issue with previous versions.
  • The laptop is new with a clean Windows installation. Only think on it security wise are the default Windows defender tools, those are disabled.
  • I killed cmdagent (at least tried that but is pops-up again), basically shut down COMODO completely. If you look under processes in the task manager, it is the Security Helper Service that is constantly messing with the disk. Eventually after a few minutes the disk usage drops significantly.
  • Can’t think of an indexer or something that could cause this.

I did find just now that COMODO internet Security is in the list of startup programs twice.
I will try to disable one and see if that makes a difference.

If nothing helps:

  • delete COMODO completely
  • Fresh download
  • Fresh installation
    Problem solved!

Disk load is back to normal, system is back to normal speed. Update messed up something, clean install fixed it.

Glad you got it fixed. I can’t help but wonder what might have caused it though … :stuck_out_tongue:

Yeah same here. I did find the two entries in the list of startup programs and disabled one of those (both pointing to CisTray.exe but can´t imagine you need to start that twice at Windows startup). Just disabling one and rebooting did not solve it. Only after complete removal en re-install the issue disappeared.
This is a bit of a quick and dirty fix. Did not really solved the problem, just created a new situation that does work.

Sometimes we just want things to work.