Zoiper Freezes at loading screen ( CIS 3.9.95478.509 - 32 Bit - xp sp3)

1.32 bit
2. XP SP3
3. No other security products running
4. Install latest Zoiper 2.21 Free (http://www.zoiper.com/downloads/free/win/Zoiper_Free_2.21_Installer.exe) and when run it freezes at the loading screen
5. To try and fix I have uninstalled CIS and upgraded to the latest version. I have added zoiper as a Trusted application in the firewall and a Safe File in the Defense+. When I uninstall CIS zoiper works. Zoiper does not show up in the Active connections list when I attempt to run it.
6. Firewall security is set to Training Mode. Defense+ is set to Clean PC Mode.
7. I have installed all software under an administrator account.

I tried to find an answer here:
https://forums.comodo.com/feedbackcommentsannouncementsnews_cis/comodo_internet_security_3864739471_released_closed-t34801.0.html;msg251415
and here:
https://forums.comodo.com/other_general_gui_etc_bugs/zoiper_softphone_stop_at_welcome_screen_cis_3865951477-t38090.0.html;new

Hi docjock,

Welcome to the forum.

Could you get rid of all Pending Files.
Put D+ in Training Mode

And try to start Voiper 2 or 3 times with all other settings as you described.

Remember to take D+ out of Training mode after the test.

Let us know result.

Did the following with no success:

  • cleared pending file list
  • Set Defense+ to Training mode
  • Started and Stopped Zoiper 4 times (had to terminate the task as it freezes)

Did the following with no success:

  • Set Defense+ to Disabled
  • Started and Stopped Zoiper 4 times (had to terminate the task as it freezes)

Did the following with SUCCESS:

  • Set Defense+ to Deactivated permenantly
  • Restarted system
  • Started Zoiper and it ran first time

Hi Bad Frogger BTW - too exited about getting a result, omitted pleasantries!

Don’t know if this is helpful but when I do successfully run Zoiper now, at around the same period where it freezes with Defense+ activated, a modal dialog appears requiring an ok button to be pressed. This dialog does not appear with Defense+ activated and I suspect this to be the culprit.

Thanks for taking the extra steps to trouble shoot.

Can you check your D+ logs and look for blocks that may be related to the app, particularly where the blocked file may be in a temp directory?

Defense+ log screen attached. I can’t see anything other than the mode switching.

[attachment deleted by admin]

OK, thanks,

There must be some compatibility issue on a deeper, maybe driver? level.

I’ll seek more help, a dev may be interested here.

Sorry I have no other option for you at this point.

Later

NP. Thanks for pointing me in the right direction. I’ll make my system available for testing if you need it.

Much appreciated.

I have PM’d CIS lead developer Egemen and sought more input from Mod board.

Later

Hi,

Please exclude the program from BO Protection.

To do so: Go to Defense±>Advanced->Image Execution Settings->Exclusions and add the program into this list,. After that it should work fine.

Hi,

I re-activated Defense+, rebooted and set the Defense+ level to Clean PC. I selected Image Execution Conrtol Settings. The slider was set to Disabled. I clicked on the Exclusions and added the exe location for Zoiper. I then attempted to run the app and it worked!

Thanks to both of you.

I have followed instructions of egemen (two messages above).

Yes, Zoiper does not freeze at startup anymore.
It makes outbound calls.
However Zoiper does not recieve inbound calls.

Configuration:
PBX on LAN (local network IP address)

Machine:
Win XP, SP3
ZoiperBiz 2.20
Comodo 3.9.95478.509