You don't have permission

Fellow Comodians (not comedians),

I’m a first time Comodo user and it hasn’t been the best first impression. But, like an eager virgin on a hopeful blind date, I’ll persist and hope to get lucky (:NRD)

I’m running Vista Home Premium with AVG. I installed Comodo yesterday. This may be a related/unrelated consequence: I tried downloading an .exe file (for the first time since installing Comodo). I get a "“You don’t have permission to save in this location” error from Vista. It offers an alternative download directory, but when I click “Yes” it displays the same error again.

In Vista > Control Panel > Turn User Account Control on or off > it’s unchecked (off). There is only one account on the machine set as administrator. I don’t want to activate the real Administrator account (command line: net user administrator /activate) and switch back and forth every time I want to install an .exe!

All the settings in Comodo are unchanged as of the first install defautl settings ie. Defense+ > Advanced > Computer Security Policy > explorer.exe is set to Trusted Application. In Defense+ > Common Tasks > My Protected Files > *.exe is listed as an Executable.

Any ideas?

Thank you in advance!

I don’t want to uninstall Comodo if she is indeed a bad date …


First of all which browser are you using? When your downloading are you using a 3rd party downloader? Did you block something that was suppose to be allowed? Look at your logs and see if it can lead you to anything.

For certain functions with Comodo involved i have had to use the real administrator account with UAC turned off to be successful. You can also try the techniques in the FAQ

First, thank you Vettetech and sded for your replies.

Vettetech: I’m using IE 7.0.6 and there are no other download managers installed. Both the logs in Firewall > View Firewall Events and Defense + > View Defense + Events are empty. Are there logs any where else I should look at?

sded: I actually read that thread before I posted. It sounds like a very convoluted way to run my machine. At the very least, I want be able to actually save the file. It’s one thing to have file execution disabled, but another to have ‘save’ disabled. Right now, I can’t save - and the only difference between yesterday and today is Comodo. Are you saying that in order for Comodo to allow the function of .exe files saving I have to run as Administrator? Yikes.

Thank you again for all your help!

I need to run as the administrator with UAC turned off to even save and restore my Comodo settings. :wink: And there are numerous other reports of Vista UAC/administrator issues with CFP3. But since I turned off UAC and always run as an administrator, and let D+ worry about the HIPS functions, problems have gone away. :slight_smile: Don’t know about your specific issue with .exe downloads, but sounds like it.