yet anther update problem

I have not been able to update my AV database in quite some time. Every time I try to update, the update downloads and installs, but seems to fail when it attempts to finalize the update. There is always a message about checking my connection, which makes no sense because the update appears to download properly.

I have manually downloaded the most recent database, but I don’t see any way to import the new database.

I am running CIS 5.12.


Have you ran the diagnostic under → ? → support

Yes, the diagnostic does not report any problems with the installation.

When I do an update, the update downloads and installs. It is on the “Finalizing” step that there is an error. It sits on “Finalizing” for a while and then gives the message,

I have attached a screen shot of the error. The error message doesn’t make sense because CIS reports that the database was downloaded and then installed before the error appears.


[attachment deleted by admin]

I have also updated my 7zip to v9.20 since there is another thread here that seems to imply that out of date 7zip could be the problem. BASE_UPD_END_USER_v18555.cav is the file that is downloaded and installed but cannot be finalized. My current database appears to be v18554.

I am still baffled that there is no feature to allow the manual import of the AV sig database. That is near the top of the list of features that AV needs to have since infection often affects the internet connection or tries to block the updater by some other means. I tend to manually disconnect infected computers from the internet to minimize access to data and prevent the infection from spreading. AV/AM software must be fully functional in offline mode to be effective in all situations where it is needed. I’m not sure that a manual method would help in this case because the database file seems to be downloaded properly, but it still seems odd for this feature to be missing.



A full uninstall and reinstall may be needed ? Before that try changing (resetting) your configuration.

I’m not sure what you mean by resetting my configuration. My settings are periodically saved in an export file. I could re-import those settings, but I’m not sure what else I could do. I don’t see anything like “restore to defaults”. Even if I re-install, I will be importing those settings again anyway.

New installations are a pain because the D+ settings are not included in my exported configuration (at least that is what I remember). That means manually restoring the D+ setting for the thousands of applications on my computer.


Another thing that doesn’t make sense is that this setup was just restored from an image that was taken on March 3. CIS says that it last updated the AV database on June 15, so it has been able to make some updates since I restored from the image. The current database number is 18554 and the one it is trying to download and install is 18555, so it does not look that out of date. I can try restoring from an earlier image and see if it will update, but the fact that it has been able to update and now cant suggests that the problem is with the update file itself and not my installation.


Hi LMHmedchem,
From the ‘About’ page under the question mark of the title bar controls you can import a locally stored Database.
If corruption is present in your current Database, you may need to rename the ‘bxxxxxxx.cav’ file to ‘bxxxxxxxold.cav’ or similar.
C:\Program Files\COMODO\COMODO Internet Security\scanners
After the new file is imported the old file could then be removed (Re-boot required to release the file).

Kind regards.

There is no question mark on the title bar of the app. The “About” page is accessed on the “More” tab, but this just gives the version numbers and a link to enter a license key.

Can I just rename the existing bases.cav file as you suggest and manually place the new bases.cav file in the proper folder?


First up, my apologies for missing the version you are using. :-[
My instructions were for V7.
From V6, there is an import function.

As far as I remember, yes you can manually replace the existing ‘bases.cav’ file in Windows safe mode only and then reboot.

Kind regards.

Well that doesn’t sound too painful. I will give it a try the next time I reboot. Graphics are always interesting in safe mode. There always seems to be something I need that is on a part of the screen I can’t get to.


I seem to have hit another snag, I can’t boot into safe mode. I have a multi-boot setup and currently the opensuse grub installation is managing things. There is not a boot option for windows safe mode in the grub menu. I suppose I could look into adding that option. Can I just rename the file from linux? That would probably be easier to do.


Hi LMHmedchem,
I am not familiar with your system arrangement, but what you are suggesting may very well work.

Keep us informed, thanks.

Well I was able to change the name in linux, but I don’t know if that did anything. When I booted back into windows, the date for the last AV update has not changed. The bases.cav file the I changed to was not the most recent, it was just the one I downloaded a week or so ago when I thought I could manually install it.

Now when I try to update, a different file is downloaded (v18624, when it was v18555 before) and then there are multiple additional files downloaded after 18624 is finished. They all seem to download and install, but again there is failure on finalization.

Updating a database file is an almost stupidly simplistic operation. It is very hard to even imagine what could be going on that would allow the file to be downloaded and installed, but not “finalized”, whatever “finalized” means. Another must have feature for any complicated application package is a verbose logging function that reports detailed information on program functions. You should be able to “start logging” and then perform a program function. You should end up with a detailed log file containing all the steps that the application went through, values for variables, error messages, etc. With that in hand, you have a means to identify where the problem is happening and the combination of states and events that triggers the failure. I have never written a complex program without such a feature and I am again baffled at the lack of it in an application as complex as CIS. An error message at the level of “what you were trying to do failed” is kindergarten programming and I expect better from Comodo, or any other payware.

Any suggestions other than to buy a different AV package that isn’t a PITA to update?


Hi LMHmedchem,
I would consider trying the latest version with a fresh install, unless you have personal reasons for sticking with V5.12.
COMODO Internet Security 7.0.317799.4142 Released!

Kind regards.

I have registered because I have exactly the same problem described in first posts here, I am running Comodo 5.8.xxxxxx (on another pc 5.12.xxxxxx, nearly identical), and the problems with updates started this month. I see there is also another user that wrote for the same problem a new topic, so the problem is spreading. I do updates from time to time, usually a week or two, and NEVER had any serious updating problems (in nearly 3 years)!
I ask to find a true solution, because this is probably a bug (with CIS or with new signatures?) and should be solved in a good way, but not uninstalling and reinstalling (or upgrading), since setting is always a pain (and also learning a new version is time wasting), here the reason that I am “stuck” with old versions.
The only way that works partially is renaming bases.cav to bases.old and copying a new bases.cav downloaded, then restarting pc - this is working (I hope it is true) as I then can read the new version of signatures in about info.
However any update from the control panel fails in the same way as it started (no incremental updates are possible), same error message (in my language) but of course there is no real connection problem.
Please study a solution, or ask who programmed the updating procedure, so it will be possible at least to know why it fails: I suspect that the incremental daily updates are “joined” in the bases.cav already present, with some cleaning of the previous database, since downloaded files are always bigger than the result of the “fusion” into new database… hence the time waiting the “finalizing” procedure, that usually ended with some hard disk activity, but now as it fails it does not pass this final step (however is not the hard disk space: I have seen there were errors in the past when space left was less than about 300 mb, of course with another type of message… now I have left some gigas to be sure).
Thank You,

Something changed today, because it was able to update as in the past - there was for sure some kind of bug in the cav files, finally it was solved - some specs: bases.cav was manually updated by me yesterday (I don’t remember what version, maybe 18997?), then today it updated regularly some incremental cav files, till to 19070 - so it finally is solved, I suggest to retry as above for all 5.x users with that kind of problem in the last month.
Thanks (to me),