Yet another nightmare install

Despite following Chiron’s clean install guide to the letter, and after many hours of frustration, version 8 (antivirus and firewall) has failed to install. No surprise as I’m used to this with CIS.

I get the message that Comodo security agent could not be started. I am asked if I would like Diagnostics to fix it. When I say yes, I’m told Diagnostics has found several errors but can’t fix them.

When I restore back to version 7, the tray icon has a cross on it, I can’t access the UI because themes won’t load, and Windows security center tells me it’s out of date.

A report has been created. Can anyone help with this, and can I upload the report so someone can look at it. I’ve had just about enough of CIS and am very close to ditching it so prompt assistance would be appreciated.

PS - I noticed others have had this problem recently (particularly Vista users like me) but have been given no help.

What other real time AV other than Comodo have you had installed ? When was the last time your system was factory restored ? If your system has the original install from 2007 then I very much doubt CIS is your problem.

Thanks for the reply. The Comodo diagnostics report lists Avast as incompatible software. I haven’t uased Avast for months and uninstalled it completely (or so I thought) also using their removal tools some time ago. Also, how was I able to install CIS version 7 if Avast was still present?

Anyway, here’s an extract of the Comodo diagnostics;

Components Error=“0x00000000” Status=“Failed”>-

Unfortunately it doesn’t give any indication of the location of Avast. I’ve looked in all the likely places and in the registry and ran autoruns to see if Avast appears there but nothing anywhere.

So, is there any way i can find the location of these Avast files Comodo says are still on my computer? Any help urgently needed and really appreciated.

Hi n01paranoid,
Have you tried the Avast uninstall utility?

Kind regards.

Thanks for the quick reply captain. Yes, I’ve run the official one and Rezjor’s unofficial one. I’ve also raised the problem on the Avast forums but so far no solutions there either.

Hi n01paranoid,
You could run a scan with the following tool and see if it can find any remnants of Avast.
AppRemover - A universal Antivirus and Security programs removal tool.
Caution use appremover at your own risk.
It fails to remove CIS completely and using this tool to remove CIS it also removes Dragon along with Dragons user profile.

Kind regards.

Thanks, really appreciated. AppRemover didn’t find anything relating to Avast. i’ve made a bit of progress on the Avast forums though. Just a couple of stubborn Avast registry entries left that I can’t delete despite changing permissions, HKLM/SYSTEM/ ControlSet001/Enum/Root/LEGACY_ASWHWID and /LEGACY_ASWMBR.

When I’ve got rid of those I’ll have another go at installing CIS.

Or if you want to try a manual strategy of removing the Avast Legacy keys you can try the following procedure.

To remove the socalled Legacy Keys, which are otherwise hard to remove, open Device Manager from the command prompt using the following two commands:
set devmgr_show_nonpresent_devices=1
start devmgmt.msc

Set Device Manager to show hidden devices under menu option View. Then look up the Avast related drivers in non Plug and Play drivers. To remove them select a driver → click right → uninstall. Remove the Avast related driver(s). When done and a reboot has been asked in the process do a reboot.

Keep us posted.

Vista Home premium ? Windows Vista Home Premium Download ISO 32 Bit 64 Bit

A link to the ISO if you can read the activation code from the Windows sticker. E-Mail me the model number and I’ll send you a Batch file that will update your Drivers and BIOS.

Happy Holidays one and all.

Thanks for all the help. Still no success though. Managed to delete those avast registry entries but CIS still won’t install. Diagnostics still shows avast as incompatible software, as shown in the report extract posted above. Is there someone I can upload the diagnostics report to so they can have a look at it?


Try the following registry cleaners to see if they can find the Avast trace for you:
Eusing Free Registry Cleaner
Auslogics Free Registry Cleaner.

When you can find the trace with cleaners all you can do is to use the search in Regedit. To be on the safe side of things make a system restore point in case you were to erroneously erase something in the registry.

Thanks Eric. Tried that and still no good. In fact Auslogics is my reg cleaner of choice (nice and safe, never had any problems with it) and I’d already used it as suggested in Chiron’s clean install guide. I’d already searched the reg and C drive using windows explorer as suggested by the Avast community and deleted everything I found.

Avast forums are now out of ideas too. I would have liked CIS firewall AND anti virus but as a last resort I’ll try and install just the firewall and use another AV. I’ve got Panda free AV running at the moment with no problems so hopefully Comodo FW will work with it. I hope this Avast problem doesn’t surface again. If there are any more problems I’ll report back here.

Thanks again - great help from everyone and really appreciated :-TU

Unfortunately more disappointment - even trying to install just the firewall doesn’t work. The security agent won’t start and avast still appears in the report as incompatible software. Very disappointing and looking as if I’ll have to ditch Comodo completely.

It’s really unfortunate the Avast forums can’t help you further to find the offending Avast registry key/driver… :-\

Hi n01paranoid,
This is a long shot and maybe not something you want to try.

Maybe try reinstalling/uninstalling Avast again in case there was a glitch with the previous uninstall.

Kind regards.

After one final failed attempt to install CIS I’ve reluctantly had to give up on Comodo. Now running Panda AV and PrivateFirewall. Thanks again everyone for the help.

Here’s what I don’t understand. Why does cmdagent fail to start when I try to install just the firewall component of CIS? Even if there are remnants of Avast free anti virus these should not conflict with CIS as I am not trying to install the anti virus component.

For what it’s worth Online Armor installed perfectly (problems with PrivateFirewall). I still prefer Comodo though so any further help on this would be appreciated.

Cmdagent.exe is a core component that is active in each guise: in CPF, CIS and CAV.