Yet another MySQL problem

I’m trying to set up a WAMP environment (not the AIO package). Apache and PHP are up and running fine, but MySQL is a trouble-maker.
I can’t properly install MySQL because at the end of installation, at the “Apply security settings” step I get MySQL Error Nr.2003 (Can’t connect to MySQL on ‘localhost’).
This has been a problem before and, as I see, it still is, but this time I REALLY NEED to make the ■■■■ thing work!
I have tried making mysql.exe/mysqld.exe/MySQLInstanceConfig.exe Trusted Applications, adding global rules for TCP out from MAC any to MAC any from port 3306 to any and the reverse ports for TCP in.
Normally it should be enough just adding it to trusted (I know, not a good idea), but apparently something is wrong.
It is the first time installing MySQL on the current setup (though I have already reinstalled it 3 times in the last hour to no avail) and I’ve spent a ■■■■ lot of nerves trying to figure this shit out, but this is simply unreasonable. There should be nothing blocking it and yet it can’t even open the ■■■■ port ( port 3306 - connection timed out even though mysqld.exe is running)!!

What the hell am I supposed to do to make MySQL work with Comodo???

Can you show us screenshots of Defense + logs (View Defense + Events) and Firewall logs (View Firewall Events)?

Defense+ permanently disabled (it’s a good feature, but it slows me down considerably), Firewall doesn’t contain any logs related to mysql no matter how many times I try to restart the installation. It is weird, but there is nothing else that could be blocking it from accessing itself on localhost (Windows Firewall is disabled, no other protection programs installed).
Disabling Antivirus doesn’t change anything.

Edit: in this topic:, a guy solved the problem by adding the executable to the trusted applications list (and I can access mysql from cmd; the service is started after all:

mysql> status -------------- mysql Ver 14.14 Distrib 5.5.11, for Win32 (x86)

Connection id: 3
Current database: test
Current user: ODBC[at]localhost
SSL: Not in use
Using delimiter: ;
Server version: 5.5.11 MySQL Community Server (GPL)
Protocol version: 10
Connection: localhost via TCP/IP
Server characterset: utf8
Db characterset: utf8
Client characterset: utf8
Conn. characterset: utf8
TCP port: 3306
Uptime: 2 min 8 sec

Threads: 1 Questions: 6 Slow queries: 0 Opens: 33 Flush tables: 1 Open tables: 26 Queries per second avg: 0.46

netstat -a -b
Proto Local Address Foreign Address State PID
TCP none-d05870e7d6:3306 none-d05870e7d6:0 LISTENING 3912

In this topic, however:
the guy tells that the problem is elsewhere and that he’s “solved it”, but there is no helpful information as to HOW he did it, at least not for normal people / in proper english.

Edit2: ■■■■, looks like it is a problem with MySQL after all…
doing this suggestion:,9293,411810#msg-411810
fixed that error for me (lazy MySQL devs, can’t fix this problem for 7 years).
It was a bit tricky though, had to run into that error, open my.ini, add the line, then restart the mysql service and then click Retry.
I guess you should keep the topic and lock it in case someone else gets the same problem, it’s easy to blame firewall since the error description clearly says that it could be firewall’s fault.

Thanks for reporting back your findings. It will most certainly be helpful.