xpcom event receiver

Hey soya

I had to open a new topic since the previous one was closed.

“This involves no connection outside your computer to the internet or a local network. The TCP option is not checked by default because, in the case of someone using a proxy server, there is a higher chance of attacks being launched using a loopback connection.”

Are we talking about a intranet here. Cuz I dont have a static IP and when I connect to my ISP i go through a proxy server again ,right?

Hey Damitha.

Your previous post was the only clue I found, and it was in reference to Free and Useful Programs that’s not locked ???. You can always contact/PM a mod to the link of the thread and we’ll open it if appropriate.

Wikipedia defines an intranet as “a private computer network that uses Internet protocols, network connectivity, and possibly the public telecommunication system to securely share part of an organization’s information or operations with its employees. Sometimes the term refers only to the most visible service, the internal website.”

I also have a dynamic IP but that doesn’t mean I run a proxy server, which Wikipedia defines as “a computer that offers a computer network service to allow clients to make indirect network connections to other network services. A client connects to the proxy server, then requests a connection, file, or other resource available on a different server.”

Don’t forget a proxy could also be defined as local software, such as Proxomitron or Privoxy.

The xpcom error seems to be a problem with firefox and thunderbird (I think its something to do with the gecko engine, so it will affect all gecko based products) I had this problem for ages, when using outpost pro and I never could find a fix.



No No…you got me wrong pal…

There was a previous post for XPCom EventReceiver…It was resolved so i couldn’t reply…
That’s why i said it was closed…

In that you’ve said that to resolve this problem try enabling "skip loopback (127.x.x.x) for tcp) and you’ve said this is not ticked by default since internal network attack can be carried out if you are behind a proxy server. Now you use a proxy server if you have a large org. If not you can simply statically assign IPs for easy management…

All i wanted to know was, whether it’s safe to enable this if I only have one Comp at home.


Well the Mozilla says that this happens when FF interacts with other applications. This could be a plugin or any other third application… And this has been present for some users after upgrading to FF 2 . And for some upgrade has resolved the problem. This is one of the major bugs that’s been there for a long time in FF it seems…

Rather than me pathetically attempting to explain it, here are better topics: