Xp Num Lock discrepancies

Xp sp3, Num Lock of course activated in the bios.

Until last week, the computer was set to boot on my administrative account without asking any credential (i know i should not, but not a real security threat if no malware is loaded, as no other physical user exists, and as all other groups and users are supposed to be denied both by windows policy and firewall).

In order to test cis lan rules as to answer to a question in this forum, i connected my laptop to the same wired ethernet router, and access controls were made easier setting a session password for the same account.

Now, and when the said password is typed, windows boots Num Lock off: what’s the issue?

XP user accounts preserve the state of the Num Lock key on logout. New accounts are defaulted to Num Lock OFF. Turn Num Lock ON and logout and the next time you log into that account, it will be ON.

Hope this helps,
Ewen :slight_smile:

Turn Num Lock ON and logout and the next time you log into that account, it will be ON.

No: it’s the first thing i do when i log the account, and still do it every day.


Do a CTRL-F on “Numlock”. They mention a couple of registry keys that should set it permanently.

You (and your link) are partially right: the keyboard indicator was already set to “2” in HKCU, but not in HK Users: for some strange reason, you need to activate it for all users to achieve the job.

Thank you.

“Curiouser and curiouser” said the cat. :smiley:

I wonder if it’s specific to the HK version? I can’t find any mention of it being language specific.


Ewen :slight_smile:

"Curiouser and curiouser" said the cat.
Free "translation" to french: "Bizarre... Z'avez dit bizarre?"

Odd, yes, but language/version specific, i don’t think so (anyhow, i’m not sure that the registry is able to “speak” whatever language but english).

Only french xp sp3 pro, i guess the said key is present in the HK Users hive in every xp computer at:
HKEY_USERS.DEFAULT\Control Panel\Keyboard (InitialKeyboardIndicators=2)

You checked for it?