XP network problem: Not enough server storage..

I’m having a problem with my home network that I’m having difficulty solving and wondering if anybody can help. I have a number of PC’s connected by Ethernet and wirelessly. They used to be able to see each other and share files, but no longer. Some of the PC’s can share files but not others. I usually get the error message:

“[PC/Folder name] is not accessible. You might not have permission to use this network resource. Contact the administrator…. Not enough server storage is available to process this command”

All PCs are running Windows XP SP2.

When I googled the above message I found a number of people who had a similar problem when they had Norton Antivirus installed. It was suggested that the registry be edited to change an IRPStackSize parameter.

I don’t have Norton AV installed, but used to have Norton 360 installed (and my network mostly worked OK). However within the past few days I have uninstalled Norton 360 from all my PC’s and replaced it with the Comodo Pro firewall and Avast antivirus. All of my PC’s are on the same network and I have explicitly also created a new network within Comodo covering all my IP addresses and placed it in the “trusted” zone to enable full sharing.

I tried altering the IRPStackSize parameter (it didn’t exist on any of my PC’s so I created it and tried different values between 12 and 45) but it made no difference. I have also rerun the Windows Create Network wizard on all PCs and checked that the windows firewall is turned off. I also tried disabling Comodo and Avast – but none of these has made any difference. I also tried stopping and restarting the “Server” services in the Administrative Tools section of windows XP.

So, none of the above have made any difference. Can anybody suggest what else I could try?

Many thanks in advance for your help.

Finally I have managed to resolve the problem. It was, after all, an IRPStackSize issue.

I checked the event viewer and it showed on some of the PC’s that there was an error 2011 indicating that the IRPStackSize was too small. It was then that I realised that the problem was not on the PC that was giving me the “not enough server storage capacity” error but on the PC that I was trying to access (the one that only showed the error in the Event Viewer).

I worked with 2 PC’s initially and set the IRPStackSize to 45 on both, rebooted, and checked if I could access the other PC’s files. It worked and I gradually reduced the IRPStackSize down to 20. I added the parameter to my other PC’s as well, and I can now get access to all of the shared files on all of my PC’s.