XP-Can't Bootup, No Safe Mode and Old CMT Problem Surfaces (Message Edited)

I have XP Home and was having some issues the way it was acting. I did scans for malware/antivirus with no results. After some extensive research on the internet, it appeared that I could very well have some corrupted window files. First I uninstalled Service Pack 3 as it stated in light that my XP upgrade disk from W98SE only had Service Pack 1 on it,it would be necessary to uninstall it & did. Tried to check the files by doing “sfc /scannow” from Run but the disk would not launch when it asked to insert it. If this did not work, it was suggested to run a repair installation from the XP disc. The process went well until the system rebooted and a blue screen appeard with a message “that a problem seems to be caused by the following file ctmshd.sys. Driver mistakenly marked part of its image pageable instead of nonpageable.” I’ve tried to boot into Safe Mode but none of the selections will work. It immediately goes back to this blue screen.

http://support.microsoft.com/kb/307545 (Rebuild Registry)

I started with the above recommendation but did not get far in the Recovery Console command prompts. After typing in md tmp [at] the command prompt & receiving a line “that it already exists”, any attempt to even complete the next prompt was futile: only 21 spaces could be used and it would immediately state that md tmp already existed.

Thru fruatration & looking over some old print-outs for use of the XP install disk and command prompts, I typed in listsvc and began to search for “ctmshd” and found the following:

Ctmflt Boot

Comodo Time Machine Bus Driver

Ctmmount Boot

Comodo Time Machine Mount Manager


Comodo Time Machine Disk Filter Driver

This software, I did use some years back using a special uninstaller instructed by Comodo to better purge the remnits of this program after a normal uninstall still kept running havoc on my system.

How do I purge these drivers out with out having Safe Mode available?

Try renaming CTMFLT.sys CTMMOUNT.sys and CTMSHD.sys by adding “.changed” to their names. That way Window cannot run these drivers.

As I am savy in some respects regarding computers, I do need help here, as how to do the above and how it should look like. How I found my problem in my post was just luck.

It appears that your response will finally get me running if I can do it right after several days without this drive that I need to get into.

Thank you so much, again.

It also makes sense to rename the ctmservice.exe so it won’t start. It is in the CTM installation folder (typically c:\Program Files\Comodo\Time machine.

There are two options here. Hook up the hard drive in another computer and rename the
mentioned files which are located in the \windows\system32\drivers folder. This is easiest.

The other option is to boot into the recovery console of Windows from the installation CD. This is described here: How to Enter Windows XP Recovery Console [Easy, 15 Min] .

Once you arrrived in the recovery concsole you will have to use commands. A lits of commands is found here: Recovery Console: What It Is & a List of Commands .

The recovery console I think will start in system32 folder. Use chdir command to access the child folder drivers. Then use the rename command to rename the files.

Now we need to navigate to the CTM installation folder. You can use command cd … to move one folder up until to get to c:\ . Then use the cd command to navigate to the CTM installation folder.

Let me know if you need more instructions.

"The recovery console I think will start in system32 folder. Use chdir command to access the child folder drivers. Then use the rename command to rename the files.

Now we need to navigate to the CTM installation folder. You can use command cd … to move one folder up until to get to c:\ . Then use the cd command to navigate to the CTM installation folder."

The above instructions posted by EricJH was attempted but I did not get anywhere: typing chdir at the command prompt did not bring anything up. The info about this command was to display at least the name of the directory-I tried other command prompts as a test with recovery console and some brought up something and others nothing, as this one.
If it is more involved, then I need an example of how it should look with the problem I’m having. I did fool around with various inputs for some time with chdir and a total “nothing”.

Is the “disable” prompt an alternative on these drivers to eliminate my Blue Screen message? If it can be, an example if what it will look like before hitting enter would be very helpful.

I’m just throwing the last point out, as now I’m frustrated.

Thank you, again.

To change to the drivers directory in system32 type in the following
cd drivers

To go one folder up type:
cd …
Notice the space and two dots behind cd. Otherwise you will stay in the current directory.

You can use both chdir or cd.

I hope the above clears things up a bit for you.

On the usual command prompt of c:\windows>, cd drivers was typed,entered with the resulting message that the system can’t find. With this same command prompt if cd … is inputted the command prompt changes to: c:> at which I tried several things but of no result.

Your instructions were straight forward but what am I missing?

Thank you

I assumed it would start in c:\windows\system32. To get to the drivers folder type the following commands:
cd system32
cd drivers

Or you can try:
cd “c:\windows\system32\drivers”

Once in c:\ can you change directory to Program Files using:
cd Program Files

I need some clarification in what I’m reading in Recovery Console and what I should see to rename the files.

  1. The prompt that I look at when I start is:C:\Windows>
  2. When I type i either cd … or cd “c:\windows\system32\drivers” the
    command prompt c:> comes up (I pointed this out in my last reply)
  3. I now assume that this is the prompt that I need to use to rename the files?
    If so, do I use rename or ren command & the exact verbage,please.
    Rename attempt that I received error message:rename c:\windows\system32\ctmflt.sys ctmflt.sys.changed
    Ren example that received an error message: "ren c:\windows\system32\ c:

I tried several variations of the above before posting again.

Thank you for your continued time.

From the symtoms you’d described, CTM had not been uninstalled cleanly in your prior attempt, to make things simpler… you may choose to rebuild the MBR of your disk drive which will disable CTM (and it’s drivers) from loading during system startup; then you may clean up CTM’s files/drivers later on when you log onto Windows.

Per your suggestion, the MBR was rebuilt and there was a message that it was successful, but the system will still not boot with the same posting on the Blue Screen.

Were my examples of Ren and Rename in my previous email to this one, “correct” that would have allowed either of them to have worked?

Thank you for everyone that is trying to work me thru this.

Hi, since you’ve rebuilt the MBR now you may give your XP disc another try; if it still fails to repair you may consider your system unrepairable ! Hope you have a system backup of some sort on hand or you may need to do a fresh system install !

Well, after Jame’s last reply I figured this whole effort was a complete waste of time. As I have experienced the “BSOD” before due to bad software and had allowed other people to use my computer, I have pretty much kept important issues on another drive. I figured that this would happen again eventually and probably of my own doing; I was trying to recoup some speed on this drive without doing a “fresh” reinstall and failed not to recognize CTM was back from my previous “bad software” whoes.

As I had nothing to loose, I began to poke around & found an access to the 3 Comodo driver files. This was not done thru the XP Recovery Console. If I’m successful, I’ll post.

Is there a CTM Uninstaller that will completely “clean” the 6MB total of these 3 and any other tid bits of this program once and for all?

Thank you

I posted a reply earliier today of my end results of my attempts to fix my BSOD from a prior CTM uninstall but it appears that it was censored, as the drive bricked. I just reaffirmed why CTM was not better than it should be. If it had been posted, it showed it was pretty objective from a user’s side but not steller for those that produced it. This will be sh__ canned. too. The prior posts,anyway, by others clearly states the terrible affairs of this software.

I’m sorry you’ve experienced a problem Graybeard, but I can assure you that nothing has been censored.

I don’t know why the post you’ve made didn’t appear on the forum, but it was not due to censorship.

Putting CTM aside, I do very much appreciate those that gave their best efforts to my posts to overcome this issue.

Thank you