XBox 360, a switch, and connection sharing [Resolved]

Hmm, I can't seem to see the 3rd page either. That's not right! (:AGY)

Here, I’ve created a new topic in the Help section, by quoting your PM. We can work through it there (more room to type)…


Okay, some questions (presuming you’re trying to share internet connection as well)…

  1. Have you used the Wizards in XP to set up Internet Connection Sharing (ICS) and/or File Sharing between XBox and computer?

  2. If so, did it work prior to installing Comodo FW?

  3. What (if any) specific problems are you experiencing with it?

  4. Are you on dial-up or a high-speed connection?

That’ll get us started…


  1. No

  2. First time trying

  3. See #2

  4. High speed DSL

I’d also like to add that I don’t have any problems connecting to Xbox Live through my current setup, it’s worked flawlessly since the moment I set it up. I can connect to the marketplace and download things no problem at all. I just can’t seem to get my pc to recognize my 360 and vice versa. Thanks for the help!

Okay, then… so internet connection is not an issue. Well that’s one thing down… :wink:

So it sounds like (if I understand correctly; no guarantees there) you are trying to do some sort of filesharing (which you said in your PM) between xbox and PC. But you haven’t set that up using Windows Wizard for File and Print Sharing…

Which then, if I understand your scenario correctly, File and Print Sharing would be the next step. You have to tell Windows you want to share your “toys.”

You also have to define a Zone in CFP, to encompass your PC, Switch, and XBox (and anything else attached to the switch - printer, other computer, etc) - Security/Tasks/Add a Zone. Then run the Network Wizard in CFP - Security/Tasks/Define a New Trusted Network to set that Zone as “trusted.” This will create two rules in your Network Monitor, at the top, to Allow IP In and Out to/from your Zone. Then you would reboot the computer.


Yes, I’m trying to share files between my pc and 360. I set up the network wizard in windows to allow file sharing. I added a trusted zone in Comodo that encompassed the ip’s of my pc and xbox but I’m still having no luck.

Check this, just to make certain…

In Windows, open your Network Connections.
Right-click the icon, select Properties.
There’s a little window in the General tab that lists the items in your connection. You should have one for “File and Print Sharing for Microsoft Networks,” and it should be checked. If not, check it, Apply, OK, Close.

Also, have you modified any Windows Services, to disable any that are considered to have security issues?

If those things check out, then let’s have a look at your CFP logs.

Try to access your fileshares; when it fails,
Go to Activity/Logs, and right-click an entry and select “Export to HTML.” Save the file and reopen it. Copy/Paste the recent activity as text into your post here. You can edit out external IP addresses that relate to your computer if you like; just leave enough to show a match where needed (or indicate where they match).


PS: Do you have the two rules that I described, in the Network Monitor?

I checked the network properties and the box is checked for file sharing. I don’t think I’ve altered any of the windows services but if you could be more specific I could try and check out whatever you ask about. I set up the trusted zone in CPF and the first two rules read as follow: Rule 0 - Allow IP out from IP any to IP zone I created where IPPROTO is any Rule 1 - Allow IP in from IP zone I created to IP any where IPPROTO is any

I must be missing something, because everytime I try and connect from the xbox all it tells me is that it cannot locate a computer with file sharing software on the network, and when I check the logs in CPF there is nothing there at all. It says nothing about blocking connections or anything that even resembles this. Could my modem be playing a part in this at all? I have a Westell 6100 and it’s supposed to be a modem/router all in one with NAT capabilities if that has anything to do with this? Just wondering, cause I’m obviously clueless about how to make this stuff work. ;D Just so you know exactly how it is setup, I have the modem hooked up with the switch which is also hooked up to the xbox all via ethernet cable. Thanks for all the help LM!!! :slight_smile:


I’m no “wiz” on physical network configuration; let me do some reading on that and get back w/you. In the meantime, one of the resident “wiz” guys may jump in.


You’re a “wiz” compared to me that’s for sure! :wink: Really, I appreciate all your help!

Here’s some FAQ about XBox 360. Looks like you might need Windows Media Connect.

And here’s some info about how to set up your computer & XBox for such things; there’s links in a box on the top-right for Port settings, troubleshooting… And yes, confirm Windows Media Connect, best as I can tell…

I think the site will be a good resource for you. Once you get that side of it set up, we can help you to configure the firewall settings they provide (which shouldn’t be a big deal; as long as you have your Trusted Network set to include PC & XBox, you should be good to go).


So I need to open ports for it to be able to work? How do I do that without making my system vulnerable? I already have WMP 11 installed, but I don’t know how to set these ports up. Is there a way to do this in CPF?

At this point, I would actually suggest running their troubleshooter. Given that you have set up your Trusted Network within CFP, you shouldn’t have to deal with any specific ports; your traffic should be allowed back and forth.

So, run their troubleshooter and see what it tells you about the communication/file sharing issues. Then post back your results here. That’ll give us a better idea what’s going on.


Hey Little Mac, thanks for all your help! It turns out there were two windows services that were disabled that I needed to turn on. Once I did that the problem magically went away! :wink:
You guys here at the Comodo forums are great and if I have any issues with CPF in the future (which this time it had nothing to do with CPF) I’ll surely be back to squeeze some more info out of you! :slight_smile: Thanks again!!!


Good to hear it worked out!

Two quick questions for you, for other users’ benefit:

  1. Which two services were they?

  2. Did you find out through the XBox troubleshooter?



  1. They were the SSDP Discovery Service and the Universal Plug and Play Service.

  2. Didn’t find out through the troubleshooters, actually emailed Xbox support and got the answer! I was pleasantly surprised! :slight_smile:

Good to know, BamaMan; thanks for the info!

I’ll mark this topic “Resolved” and close it, so other users will know there’s a potential solution for them …

If you need to reopen it, please PM me or another Moderator with a link to the topic.