wrong date on comodo time machine

I am having problems with win 7 64 bit with lots of blue screens, eventually uninstalled skype which fixed it until today when I installed then uninstalled iconix and then installed a logitech mouse (using their setpoint software). blue screen afterwards. Wanted to system restore so went to Comodo timeline but the dates are all wrong. It doesn’t show a date later than 14th April when I know I got it to do a snapshot today 30th april.

So I tried to use sytem restore (windows) but it won’t do it because of sfi.dat which is also a comodo problem from CIS. So what CAN I do - I am stuck with a pc that keeps crashing and I can’t restore because a) system restore won’t work and b) I have no idea what date I am restoring to with time machine as the dates are all wrong

I would like to uninstall the lot but it seems that even that could crash my hard disk according to other people on here! PLEASE someone help me! I am not that computer literate but not too bad …