Wrong certificate with Comodo Internet Security Firewall Driver

with Comodo Internet Security Firewall Driver active on my network i have some issue some time when using

or Add this plug in for wordpress.

Why and what happend?
Is explained here: Issue with share email, captcha | WordPress.org
and on this article
Possible phishing problem. Having certificate problems when browsing on a particular site. - Virus, Trojan, Spyware, and Malware Removal Help

With this driver on my network if i try to open the URL https://s3.amazonaws.com/ i see wrong certificate so many website not work because use this to store data like github.
Is a comodo issue?

No also with the driver deactived now not works… i can’t understand…

Can be my ISP issue? Maybe is COmodo issue. Now i have removed DNS of Comodo in all the way and issue can be now solved. Please Comodo tema check this.

IT seems for solve the issue you have to uncheck Comodo Firewall Internet Security Driver and also edit IPV$ info removing the comodo secure DNS.

So if COmodo DNS is removed the issue seems to be solved.
The issue is on COMODO DNS, CSI or Driver

Without I’M able to open always this https://s3.amazonaws.com/ so all website who hosted content there now works and stopped to have issue.
With Comodo DNS this address: https://s3.amazonaws.com/ some times works, some time not because you see wrong certificate.

[attachment deleted by admin]

Maybe this topic shoul moved to bug section.

I am not expert on how web sites work and how to read error with retrieving external content i.e. “nucaptcha.js:1 GET https://s3.amazonaws.com/staticd.nucaptcha.com/23501/v6/skins/addthis/skin.css net::ERR_INSECURE_RESPONSE”.

The problem may not be pertinent to Comodo Firewall driver. First you disable Secure DNS and that solves it . Then you try to disable the driver as suggested in the bleeping computer topic but that did not work.

Then in your second post you find that disabling the firewall driver helps. That is inconsistent with your first finding where disabling does not work. That leads me to believe that firewall driver is not the problem.

Then you report that using Secure DNS sometimes causes the problem and sometimes it doesn’t.

Your observation about the firewall and Secure DNS are inconsistent and lead me to believe the problem lies elsewhere.

Let’s start with clean slate and enable the firewall driver and not using Comodo Secure DNS but the ones from your provider. Also make sure to clear your DNS cache when browsers are not running.

Also disable all addons in your browsers when testing.

I had resolved stopping to use comodo DNS.
All work fine now, i think i will not use animore comodo DNS and i will disable for all user.

It’s something in comodo DNS who male it wrong.
For resolve the issue i have removed the driver but the change most important is remove in ip4 the comodo DNS as showed here:

Until this far your findings are inconsistent:

First you says (part in red) that you need to disable both Secure DNS and firewall driver. Then you say using Secure DNS (part in blue) solves it. Then you say (part in blue) using Secure DNS sometimes solves it brings on the problem and sometimes it doesn’t.

Those are all inconsistent findings and not evidence of a problem with firewall driver or Secure DNS

We need to establish what is going on and I am urging you to see what happens when you enable the driver again while not using Secure DNS.

At all users. Please keep in mind that disabling or removing the firewall driver disables the firewall. Disabling the firewall driver is never a solution and should only be done briefly for testing purposes only.

My troubleshooting gut tells me the problem is most likely not in the firewall driver but more upstream. The problem is more likely with the browser or with secure connection (may be there was a problem reaching the revocation server of the Certificate Authority). Both browser and web are more unstable then a firewall driver. Also the error “net::ERR_INSECURE_RESPONSE” does not point to a problem with DNS. In case of a DNS problem I would expect an error saying that the address could not be resolved.

I want to troubleshoot the problem to see if we can reproduce the problem with consistent findings. We must also consider the problem was a temporary problem.

Incorrect, he says that with Comodo DNS (Secure DNS) it sometimes works and sometimes not.

Thanks Sanya. I fixed my post accordingly.

I think you fixed it the wrong way around…

It says

But should be

… Just Sanyain… I believe the underlying issue here is a misunderstanding. Where you think peopleinside said that SecureDNS OFF = It works sometimes and sometimes not, while peopleinside said that SecureDNS ON = It works sometimes and sometimes not and that SecureDNS OFF = It works.

Or perhaps it’s me who is misunderstanding, perhaps all of us are misunderstanding each other? Is this even the Comodo forum or is that a misunderstanding? :o 88)

I edited my post once more.

Bottom line is that the finding are inconsistent about using Secure DNS or not and whether the firewall driver plays a role or not.

That why I want him to show reproducible results starting with the firewall driver enabled and Secure DNS disabled. The problem is intermittent and could be caused by factors upstream.

It seems is not the driver but the Comodo DNS.
Now Driver Firewall is active and DNS disactive, all works fine.

Thank you for trying and reporting back. Can you also try enabling Secure DNS again to see if the problem reproduces?

Yes, for now I’M unable to reproduce right now. DNS Acrived and Driver Firewall active.