Wow! Killed

Previously I’ve only used the registry cleaning and drive cleaning functions of CSC, but yesterday I decided to “Power Clean” my system.

I made backups (good thing) everything looked well initially so I finalized the process. Then later in the day I tried to fire up to do some word processing and was surprised to see that it was asking me to register. I just thought it must of wiped that stuff, no big deal. I’ll just do it again. After clicking the ‘finish’ button, it locked up. I had to kill the soffice.bin process from the task manager. Another attempt did the same thing.

So I decided to try to do a ‘repair’ install of OO.o. That was successful, but it still wouldn’t run. Same problem. So I completely uninstalled OO.o with Revo Uninstaller to ensure everything was gone, and did a clean install. It still wouldn’t work!

I decided to restore the backups that CSC made and surprisingly enough, everything works fine now…

I have no idea what CSC could possibly be cleaning that would cause even a complete clean install not to function, but it did. I haven’t ruled out whether or not CIS could have been blocking something, (The cleaning did remove soffice.bin from my Computer Security Policy) but attempting to start OO.o in clean PC or training mode was also unsuccessful.

CSC version 1.1.64942.34. version OOO300m9 (Build:9358)

AMD Athlon64 X2 dual core 4200+
Win XP Pro SP2 32bit

CIS version 3.8.65951.477

After getting a PM from Vraciua saying that the issue was reproduced and asked me to see if the problem still happens if is not included in the privacy clean process.

It turns out the problem is with the privacy cleaner. If you un-check OpenOffice from the privacy cleaning module, after cleaning OO.o functions as it should.

The privacy cleaner does tell you you could lose sensitive data prior to cleaning, but I have to question the logic of cleaning data so sensitive that it breaks an application so thoroughly that even a complete clean install of the software still doesn’t function… (How is that even possible? ??? )

If it’s so sensitive, I would suggest removing OO.o from the list of privacy cleaning options because it’s only asking for problems with users. Or at the very least, don’t clean whatever it is you clean that kills the application.