World of Warcraft not working

Basically the problem is this… World of Warcraft doesn’t work since I installed Comodo firewall!! I can start the launcher, I can even apply updates but the second I hit play to enter the world, my screen goes black. no noise, no keyboard reaction, not able to restart or Alt Tab, it hangs the computer!!! this is the the only reason my computer exists, to play WOW, please don’t make me go back to Norton!!

Right click comodo tray icon and change defense+ and the fire wall to training mode. Play WOW for 5 minutes then change the firewall\defense+ back to SafeMode.

Hope this helps!

The same thing occurred but thanks for the attempt :slight_smile:

Delete all the rules you have for WoW n both the Firewall and D+, then put both the Frewall and D+ in training mode, disable the sandbox, and then open and play the game for a time. Exit the game, put the Firewall and D+ back to safe mode or whatever mode you prefer, leave the sandbox disabled, and try to play the game. It should work if you do all those things. I played WoW with CIS for a year.

Since the last Comodo update (Ver. 5.0.162652.1142), D+ has prevented the World of Warcraft game connection from launching. The only way to get WOW to play is disable D+. The D+ log says it flagged wow.exe as a Shellcode Injection. I spent about 5 hours on this, because the Comodo update coincided with a World of Warcraft update. I thought it was a World of Warcraft update problem when in fact it was a Comodo D+ problem.

You have to put WoW as trusted application first of all and if defense+ asks again then click “treat as: Trusted application”

I hope it helps:)


Please try adding the wow executable or the complete wow installation folder to the Exlusions of shellcode injection.