World of Warcraft issue. Getting Error #0; (from their error report)

Defense+ crashes World of Warcraft on connect.

The bug/issue

  1. What you did: I attempted to log into World of Warcraft after Blizzard’s cataclysm launch.
  2. What actually happened or you actually saw: The game outright crashed.
  3. What you expected to happen or see: Bringing up the character selection.
  4. How you tried to fix it & what happened: Turned off Defense+, added WOW.exe to defense+ safe list.
  5. If its an application compatibility problem have you tried the application fixes?: I tried any WOW fixes on their site, and a few obscure ones in other places. Updated all drivers, windows files, directx, etc.
  6. Details (exact version) of any application involved with download link: Latest WOW patch as of 12/9/2010
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Enable Defense+
  8. Any other information (eg your guess regarding the cause, with reasons): I’m guessing it’s something with how Blizzard re-programed and their downloader to work in the latest expansion. Adding the exception didn’t work, only turning off defense+ has worked. If I re-enable it, it crashes.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: Comodo doesn’t show as having a bug.
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: Doesn’t even show closing /crashing it.
  3. A CIS config report or file. Comodo doesn’t crash, there’s no log of it blocking anything.
  4. Crash or freeze dump file: From WOW?

Your set-up

  1. CIS version, AV database version & configuration used: up to date as of 12/9/2010
  2. a) Have you updated (without uninstall) from CIS 3 or 4: No
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: no
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here. )I test a lot of freeware, blocking unknown files is a no for me. my rule is if i’m not doing something, I block it.
  5. Defense+, Sandbox, Firewall & AV security levels: D+= any but OFF , Sandbox=enabled , Firewall =safe/custom mode, AV = on access
  6. OS version, service pack, number of bits, UAC setting, & account type:Windows 7 Pro x32, UAC, windows defender, firewall all off; winxp pro SP3 firewall turned off;
  7. Other security and utility software installed: tons, but nothing active. I use spybot S&D as well as advanced system care free to immunize the system if I remember to. Haven’t had a problem with viruses or spyware in so long, I don’t always do this, however I realize the importance of having some protection against then, since I clean that bull@!@# for a living as part of my duties as a sys admin/help desk personel.
  8. Virtual machine used (Please do NOT use Virtual box): VM = null on both boxes.

Hey and Welcome!

you need to put WoW.exe in the defense+ and this how you do it.

CIS —> Defense+ —> Computer Security Policy —> Defense+ Rules —> Add —> Select —> Browse…


Nevermind... the tech on hand didn't know what she was doing and tried to take a shortcut. Adding it to the excluded files in Defense+ did allow it to work.
~~~~End Edit~~~~

4. How you tried to fix it & what happened: Turned off Defense+, added WOW.exe to defense+ safe list.

I did a multitude of other things, but adding it to the exclusions list/defense rules did not work. I also added all other .exe files as well. The only thing that allowed me to get past the error I'm having was turning off Defense+, which is how I know it's a problem with this.

Sorry if i'm confusing, I've been told my way of speaking often confuses people.

Thanks for the welcome!

don’t disable defense+


I agree, which is why after some more testing this morning, I decided to post a bug report. I was pretty sure I added it to the windows 7 defense+ exclusions, and I remember it working before trying to sleep last night, but my girlfriend told me it wasn’t working this morning. Usually, that means it doesn’t work on her computer, the xp box, or my computer.

Apparently she was lazy and decided not to test mine, or listen when I tell her the defense+ exclusions are different than the firewall ones…


[list]Falstagg. Can you try the following two workarounds and see if they do anything for your situation:

  • add the offending executable, or the complete WoW folder, to the exlcusions of the shell code injections (Buffer Overflow detection) under Image Execution Settings

  • give the offending executable the Installer/Updater policy

When done add your finding under point 4 of bug/issue in your bug report.

this how you add the WoW folder in exclusions:

CIS —> Defense+ —> Defense+ Settings —> Execution control Settings —> Detect shellcode injections (i.e. Buffer overflow protection) —> Exclusions —> Add —> Browse…

Now find WoW folder in Existing items and move it to Selected items, by ->.


I can confirm that the above resolved the problem.

!ot! since the problem is solved

then look see this as a/an hint/advice in case you need to add something else there. (Deamon tools for instance)

Have fun gaming:)


Thanks one and all. Moving to resolved.


Huh, didn’t get notified that there were further replys, only that the topic was moved.

Noxcivis is correct, adding the WOW.exe to the exclusions list did fix this problem for me across all platforms.