workrave.exe automatically sandbox on launch even if added to trusted files[NBZ]

When I add workrave.exe to trusted files, exit from workrave and launch it again, it is automatically sandboxed.

The bug/issue

  1. What you did: I launched Workrave manually from the Start menu, got the alert, clicked ‘Dont’t isolate again’, exited Workrave and launched for the second time from Start menu,
  2. What actually happened or you actually saw: Sandboxing alert was given again.
  3. What you expected to happen or see: The workrave should launch without sandboxing when added to trusted files.
  4. How you tried to fix it & what happened: removed from unrecognized files, ensured that it was already in trustred files (!!!) and rebooted, same behavior
  5. If its an application compatibility problem have you tried the application fixes here?: not a compatibility issue, Workrave works normal, but exiting from it leaves a dangling tray icon (which is removed when hovering over it), workrave may be crashing on exit.
  6. Details & exact version of any application (execpt CIS) involved with download link: Worksrave 1.9.3. Download Workrave · Workrave
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: always reproducible.
  8. Any other information (eg your guess regarding the cause, with reasons): I cannot submit it for analysis as the binary is too large.

Files appended

  1. Screenshots illustrating the bug: none

  2. Screenshots of related CIS event logs or the Defense+ Active Processes List: none

  3. A CIS config. report or file: none

  4. Crash or freeze dump file: none

  5. CIS version, AV database version & configuration used: CIS version 5.3.176757.1236, Defense+ and Firewall modules installed (no Antivirus). Proactive config.

  6. a) Have you updated (without uninstall) from CIS 3 or 4: no

  7. a) Have you imported a config from a previous version of CIS: no

  8. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): yes, and raised levels to more paranoid.

  9. Defense+, Sandbox, Firewall & AV security levels: D+= Safe Mode, Sandbox= Partially Limited , Firewall = Custom Policy, AV = not installed

  10. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 Ultimate English, x86, administrator account with UAC on (highest setting).

  11. Other security and utility software installed: ESET antivirus, 0110209 virus signature database.

  12. Virtual machine used (Please do NOT use Virtual box): none, but VMware Workstation 7.1.1 is installed. Problems occurs on host OS (guest not tested).

Could you please add the missing information to your first post.

  1. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 Ultimate English, x86, UAC on (highest setting) Adminstrator or Limited.

Thank you


I have edited the first post to include: “administrator account with UAC (highest setting)”

Thank you for your bug report in the required format.

Moved to verified.

Thank you