won't update anymore since i did a system restore [Solved]

I’m using Windows XP with CIS premium 5.10.

When i start up the computer, the AV database updates fine, but 2 days later, I get the windows security alert about AV not being updated. When trying to update the database manually, it gets all to way to 90% (“finalizing”), then a few minutes later it says the update failed. If I restart the computer, it updates fine on windows boot up.
The only thing i can think of that’s changed was that i did a system restore about a week ago (not something major, just restored to a day earlier) and since then the problem started. Could that be the cause of the issue? and if so, why is it successful at the windows start up but fails later?
Mod edit: Added solved to the topic title, Captainsticks.

Does the following procedure help you out:

I don’t have a ‘bxxxxx.cav’ file in that folder.

Hi
For version 5.10 please try the following.

  1. Boot into Windows Safe Mode.
  2. Copy the bases.cav file from C:\Program Files\COMODO\COMODO Internet Security\repair folder to the C:\Program Files\COMODO\COMODO Internet Security\scanners folder, replacing/overwriting the existing file.
  3. Reboot normal, then try to manually update the DataBase.

Kind regards.

well, i did it, but i can only let you know if it worked two days from now, since updating after a reboot worked fine before anyway…
see you then

edit: seems to work fine now, thanks.

You are welcome, let us hope it continues to behave. :slight_smile: