Won't scan, won't initialize update

Hi all. I’ve seen similar problems posted to this forum, but not mine exactly.

I use CIS 5.0.163652.1142 and I’ve been very happy with it. My OS is Win7 Ultimate. My machine is a custom tower, Intel Core2 Quad 2.4 GHz, 4GB RAM.

Today, I tried to scan some items which I’d downloaded. I got an error saying “could not initialize scanning engine,” and then my machine crashed and rebooted. When I opened the program interface, it shows me the yellow shield saying that I have not performed a full scan yet. That’s untrue, because I’ve used this program for a few weeks and I’ve done a full scan many times. When I try to run a system scan from the program’s interface, I get an error saying “update failed, antivirus engine is not initialized.”

The diagnostic tool shows no problems, and I always, always keep the program updated. CIS has been fine so far, no conflicts with any other security software which I run. I haven’t installed anything new.

Is anybody else having this problem, or does anybody know the solution? Please help, and thank you!

Welcome to the forum floridaze :slight_smile:

Please read here


Thanks Dennis! I appreciate the welcome and the quick response. :slight_smile:

I followed the instructions under this post in the thread which you recommended, and it didn’t help my problem: https://forums.comodo.com/empty-t64112.0.html;topicseen

I had not changed any settings on CIS recently, and had not installed any new security programs. Very strange … it simply stopped working correctly today after being fine yesterday. :-\ ???

make full system scan with a updated malwarebytes.

Yes, good idea. I’m nearly positive that I have no virus or other malware, but I’ll run a scan with MB to be certain.

Another idea – last night, I ran CCleaner and Advanced System Care. I only deleted privacy and junk files, no registry items. Could that be the problem? Should I rollback to my restore point from before running those programs?


I don’t think this is the problem. I’ve never had issue like this from either of those programs, although I haven’t used Advanced System Care in quite some time. But if you do have a restore point prior to running those processes, it couldn’t hurt to give it a try.

Thank you very much. I’m glad to hear that these programs normally don’t cause programs with CIS. :slight_smile:

Malwarebytes is showing no infection, as expected.

I just don’t know why CIS stopped working for me suddenly. I’ll try the system restore point which I created last night and see if it solves the problem, for whatever strange reason. I don’t think that’s the problem, because I had used both programs before with limited deletions, and CIS remained fine.

Thanks, everybody! :-*

Maybe I should do a deep uninstall of CIS using Revo, and reinstall? I read the person on the other thread saying it didn’t help, but his/her problem seemed to be with MS Office.

CIS diagnostic says there’s nothing wrong with my installation of the program, but maybe a reinstall is worth a try?

I’m sorry to be a pest. It’s just that I love this program and I want to keep it, if it functions correctly for me again. :-\

Yes, you could uninstall with Revo and reinstall. Sometimes a reinstall is the only fix.

I think I’ll try that before system restore. I downloaded a few programs last night, to be installed later, and I don’t want the installers erased via system restore.

Thanks to everybody!

System restore doesn’t backup your entire drive. Your downloads will still be there if you restore. If you’ve installed any of them however, you’d need to reinstall them.

As you ran CCleaner please check you have Windows/Temp folder.

Thanks for the tips about sys restore and CC.

I did an uninstall and downloaded the latest version from this site, even though my program showed the latest version. I thought I should get the latest installer instead of using the one I had saved on my comp and updating from that. It worked! Everything seems to be scanning without a problem now.

A strange thing is that Revo did not detect CIS even being on my comp. It has done that with other programs, so maybe it’s just a glitch in Revo. Whatever the case, the CIS built-in uninstaller seemed to do fine.

Many thanks to all for the friendly advice! :-*