Won't install again.

I already had Comodo Firewall Pro (32 bit). But since the last two days or so, it has been giving alerts that updates are available, and I tried updating twice, but the update process broke off midway. So I decided to download a new copy from the site and uninstall the old one and install the new one. The new one has the same number:

What happened is, I uninstalled the previous firewall, and now, when I run the setup from the new file, it gives the message that Comodo Firewall is already installed, and would I like to uninstall it? But I’ve checked, in the system tray, it is not there (only Comodo Memory Firewall and Comodo BOClean is there). I tried uninstalling and reinstalling two to three times, and rebooted the computer as well, and deselected the entry “C:\Program Files\COMODO\Firewall\cfp.exe” -h; and then rebooted and tried to install again, but it keeps giving the same old message.

So what could have gone wrong?

Another thing: I have Bitdefender Total Security, so I decided to use only the firewall option of Comodo, not the suite that is available (with antivirus), but I’ve just noticed that the firewall in Bitdefender is on, and has been on all this time, since every time a program tried to connect, both Bitdefender and Comodo would ask for permission. I’ve heard it is advisable to run only one antivirus and one firewall at a time. Could this be the problem (though I don’t see how, since the installer is saying that Comodo Firewall is already installed).

And yes, in the folder “C:\Program Files\Comodo\Firewall”, all the files are gone, but there is one file remaining - “cmdagent”, and that won’t delete, it gives an access denied message, and even Unlocker is unable to unlock it.