Won't accept my email address

I originally downloaded and installed EasyVPN onto my 32-bit Vista SP1 just a couple weeks ago (around June 12th, as I recall) and played with it with no problems to speak of.

Then, to my chagrin, a vexing (and huge) .Net problem which even Microsoft couldn’t fix cropped-up and finally made me do what I’m always both loathe to do, and which I tell others should never have to be done:

   I backed-up everything and reinstalled.  Ick.

At any rate, I’m now running a brand, spanking new, pristine copy of 32-bit Vista SP2. So far, so good.

So then I downloaded a new copy of EasyVPN again (I think it was on Friday 26 June 2009); then I logged-in using login and password I had established when I downloaded it and created my account a couple weeks earlier.

Again, so far, so good…

…but then, when I went to the “Settings” screen, and tried to key-in my email address, it wouldn’t take it.

It kept telling me to enter a valid email address… but, of course, my email address is/was valid… not only does it actually exist and will resolve (just in case EasyVPN was checking), but it was also keyed-in in the proper format.

To save my life, I couldn’t make it take it. I finally got to ticked-off that I uninstalled EasyVPN. But that’s a frustration, because I actually want to USE the darned thing

So, then… any thoughts, anyone?

Thank you for the report. This is really a bug, and it should be fixed in the next release version.

And WHEN will that be? It has been over a month since the message to which I’m now replying was posted; and months since the last release. Is this software still in development, or is it time to just give up and start using Wippien (http://wippien.com/)…

…'cause I’ve got clients and others who are asking me which software to use; and after talking-up EasyVPN, I’ve got serious egg on my face right now. And I usually only let a vendor do that do me ONCE.

So, what’s it going to be? Is this going to be fixed in my lifetime, or what?

If so, when?

Tick, tock.

The latest version of EasyVPN has, apparently, had the problem described in my thread-starting post here corrected…

…only to be replaced by what I suspect is a variant thereof wherein EasyVPN seems to remember NOTHING about me with each new reboot.

Even if I login and then go into the area where I tell it my full name and email, etc.; and even if I also configure it in all places so that it’s supposed to remember me and auto-log me in with each startup…

…it doesn’t do ANY Of those things. Each time I reboot the machine, EasyVPN tells me, when it starts-up, that the login information I’ve given is wrong, and that’s because there’s nothing defaulted into any of the fields. And all of the checkboxes where I told it to remember me, etc. are unchecked. And if I give it the credentials and login, then go into options, my full name and email address are not there.

I’m using 32-bit Vista SP2 on a dv6000-series HP Pavilion notebook. Plenty of RAM, plenty of hard disk space, nothing running which conflicts with anything or makes anything misbehave…

…er… that is… apparently… WITH THE EXCEPTION OF EasyVPN!!!

Does EasyVPN only work on XP or something? Is THAT the problem?

When is this promising-but-disappointing product finally going to actually WORK?


Any news when this bug will be corrected?

It appears, with the absolutely latest version, to be fixed, but in order to make that true for me, I had to COMPLETELY uninstall (and I mean very aggressively… using REVO UNINSTALLER, and then even going back and manually removing all files, folders and registry entries which contained the text string “EasyVPN”) the product, and download and install the absolutely latest version.

Only after doing all that did the latest version of EasyVPN start pretty much “remembering” me.

However, it still doesn’t remember at least the login credentials quite right. For me, at least, anything defaulted into the login fields will not work… I get a “The login information you have entered is invalid. Please enter the correct data and try again” pop-up error.

But when/if I either manually re-type the login credentials, or if I select them from the drop-down selector in the “Username” field, then it will log me in okay. And then when I go to the “Tools” pulldown menu, and select “Options,” I notice that it seems to be remembering my email address, and my first and last name, and even my display picture.

This memory, now, seems, for me at least, to survive closing and re-launching the program; and even rebooting and then relaunching the program.

The biggest thing which I see, now, is that anything defaulted into the login fields just won’t work; and so login credentials either need to be typed-in or chosen from what’s shown in the drop-down selector in the “Username” field.

So, that’s definitely progress. But it’s still not there yet.

I’m working on a VERY detailed posting in this thread…

 <i>EasyVPN doesn't remember a single thing about me</i>

…where I will be detailing the results of my testing, and having a few rants, etc. Give me a little time to finish it and you’ll see it there.

I’m pretty sure I have the latest version and it doesn’t like my “.org” email either…however another email I used worked just fine…unfortunately it’s an email I can’t access everywhere inside our network which is lame.

I am unable to register/create an account from the EasyVPN GUI. I keep getting an error “Please enter a valid email address”. I just downloaded and installed yesterday so I assume that I am on the latest version. My email address is my own domain but it is a com address, the only oddity is that there is a hyphen in the address. I have another email address I could try but I really want to use this one. Any ideas?

*** Jay ***