Wireless Printing

I just installed the Epson software to print to wireless 810 printer. But I can’t print to the printer. How can I check AV and Firewall. To see if it is preventing my printer to printer? :cry:

How can I configer my AV and Firewall for my wireless and wired printers? ???

This may require various angles.

Let’s start with seeing Epson printer software executables get sandboxed. Go to Unrecognised Files and see if there are executables belonging to the Epson printer software. If there are select them all and move to Trusted Files. To unsandbox they need to be restarted; reboot your computer to do so and report back.

When that doesn’t do the trick post screenshots of the D+ logs (View Defense + Events) and Firewall logs (View Firewall Events).

I believe it’s a firewall issue, not an AV issue, Dairygoat.

And the solution, I think, is to open Comodo Internet Security (CIS); and then,

click on the “Firewall” button (that’s part of the bank of large horizontal buttons across the top); and then,

click on “Firewall Behavior Settings”; and then,

click on the “Advanced” tab; and then,

uncheck the “Block Fragmented IP Datagrams” box; and then,

click on the “OK” button; and then,

close CIS.

I don’t believe a reboot is necessary, but, what the heck, it never hurts to just go ahead and restart Windows after a change like this, just to make sure everything both works and sticks properly.

If it works (and, please, Darygoat, let us know if it does), it’s not because I’m so smart (though if I’d just shut-up and not make these full disclosures, I’d get to enjoy everyone at least thinking I’m smart): I was remotely logged-in to a Win7 machine just this past weekend, trying to help a client whom I had just convinced to uninstall Norton and use CIS, instead; and after we got it installed and I tried to print something, she said that nothing was coming out of her HP wireless printer (and that it was working fine before CIS was installed).

Of course, I did all the normal, basic checks… printer on, no error messages, spooler working okay, wireless adapter working okay, yadda, yadda, yadda. No joy.

Then I disabled the firewall, and, voila!, it worked again. Then I re-enabled the firewall, and it stopped working. So, obviouly, it was the firewall. I fiddled with making the printer port “trusted,” and the “spooler” trusted, and all kinds of other obvious silliness. Still no joy.

So, then I searched around and I found a thread, here, from… lemmee think… I think it was 2007…

…and it specifically mentioned her model of HP wireless printer and whatever CIS version was current back at that time in 2007. The person who started the thread was complaining that his computer was communicating with his HP wireless printer just fine immediately before he installed CIS; and someone who obviously knew what the heck he was talking about chimed-in to the thread and specified exactly what I just specified, above…

…and the thread-starter posted, a couple hours later, that it bygolly worked!

I have no idea, however, if it will work with your particular brand and model of wireless printer, Dairygoat, but after reading-up a little on exactly what that setting does, I have a sneaking suspicion that it will. I could be wrong.

Again, let us know if it works, Dairygoat. If it does, then I suspect it would work with most any wireless printer that suddenly stops working after CIS is installed. And, if so, then maybe this thread should be made sticky…

…though not here in the AV section but, rather, over in the Firewall section (to which I’m here and now suggesting, EricJH, that this thread be moved, in any case, since, even if it doesn’t work, I know that I’m at least right about it being a firewall, and not an AV, issue).

If it does work, I further suggest that Comodo’s tech people experiment a little with various wireless printers, and then, if it seems to fix communications problems with all manner of wireless printers as it did with my client’s this past weekend (and as I’m hoping it will with Darygoat’s machine), then I think Comodo should both add trying it to some kind of troubleshooting documentation or FAQ or somehing, and/or the CIS user guide; and I’m also wondering if it would make sense to add to the little paragraph of information under that datagram checkbox in CIS, itself, that unchecking said box could potentially resolve local wireless device – particularly printers - communications issues which may crop-up after installing CIS.

Or, who knows… maybe it won’t work in Dairygoat’s case. All I know is that it worked, beautifully, day before yesterday with my client and her Win7 machine and her HP wireless printer.

Hope that helps (fingers crossed)!