wireless printer appears offline after installing CIS [SOLVED]


I recently installed CIS on my XP laptop, what a great product! However i cannot connect to my wireless Brother printer anymore.
The printer works fine and connects to the wireless network fine, but doesnt seem to detect laptop. laptop connects to network fine, but doesnt see printer is online.
I removed CIS but still had the same problme!
I have reinstalled printer driver and software, reset printer network settings, etc etc but no joy

I have reinstalled CIS now as i didnt want to be without protection.

Another laptop that didnt have comodo still sees printer fine and printer sees it, so it must be a comodo setting. I reset the option to assign dns automatically rather thn use the secure comodo ones, but that dint help.

Any suggestions?

find out the IP of the printer and add an exception to the firewall for in and out traffic.

i’ve just done that, under network policy, but printer still appearing offline

try this, turn off the printer. put firewall in training mode, then turn the printer on. Wait a minute or so and then try to print something, if it works, go and put the firewall back into safe mode. Let me know. Thanks.

no joy!

then it must me something else. Do you have windows firewall turned off, so you are not running two at once? Also have you checked under control panel, networking, change adapter setting, right click properties and make sure file and printer sharing is selected?

i’m pretty sure printer sharing is allowed but cannoot find the option using that path (i have xp)

windows firewall was on. turned it off then restarted printer, still no jou

in xp it is, control panel → network connections → right click on the network connection → select properties.

sorry still cant find that setting! I right click on my wireless connection icon, select properties and get the properties window with general/wireless networks/advanced tabs but cant find it. i do apologise.

it should be under the general tab, it should look like this, plus of course the driver for comodo firewall should be listed as well.


FYI: The driver for Comodo Firewall are never listed in any Network Properties for Win-XP.

file and printer sharing is definitely enabled, thanks for that

cant see a comodo driver listed

ok well the next thing to try it to turn off the printer. Then put the firewall and D+ in training mode. Then turn it on, try to print a page. If it works put everything back to safe mode. let me know.

no still no joy!

I’ve justed addded my daughter’s laptop to the network and it connected to the printer fine, so thta confirms it is to do with my laptop. it was definitely connecting to printer fine before i installed comodo

thanks for your help, much appreciated

try this, put firewall into training mode and d+ into training mode. Then turn off the printer. Reboot the laptop, once rebooted turn the printer one. See if you can see it now.

no, no luck, printer still appears offline (and is offline, i tried printing , it didnt work).
this is using the system tray icon that comes with the brother software

i just looked in control panel/printers and faxes and the printer is listed there as ‘ready’, not offline. test paage failed to print though, so it is definitely offline

is it worth reinstalling brother driver and software with firewall and d+ in training mode?

that’s what i would do.

heck, that worked, printer appears online and a test page printed!!!

firewall and d+ still in training mode, dare i go to safe mode?

yeah go to safe mode you should be fine now.

yes back to safe modde and printer still available

thanks very much for your help!