Wireless connection stuck at acquiring network address


Today I installed and started using Comodo firewall. So far things have been going pretty well, but I have a possible problem with my internet connection. I connect over wireless using the built in windows zero wireless utility and it seems to be getting stuck at the “acquiring network address” stage. However, I can freely access the internet and in the support tab of the status window it says I have been given an IP address by the DHCP server. Like I said, I can access the internet and it works, but the status remains at “acquiring network address” and the icon in the taskbar remains in its connecting animation state.
I’m not sure if this is the fault of the Comodo firewall, but it did start after I installed Comodo. I’ve granted access to the svchost service as well as the “System” and the DHCP Client service is set to automatic. Any ideas on what is going on or what I can try?

Thank you!

This is a well known bug in XP that seems to be worse with some other programs involved. You can go to “internet connections” and use the F5 key to make it refresh and show the true status.

wow… that was surprisingly simple. Thanks a lot!

Glad it helped. Maybe SP3 will finally fix the problem. :slight_smile:

I set svchost and the System to Outgoing Only, and the problem seems to have gone away. However, now my internet connection is super slow. What settings should I be using for these processes?

I am running Vista, which is probably a bit different than XP. I don’t have any explicit firewall rules for svchost, and system is set to allow udp and tcp out. I think many rules end up under Windows Operating System in the latest CFP3. My firewall system related rules are attached. I don’t have any global rules.

[attachment deleted by admin]

I didn’t have any policies set up for the operating system as a whole. I tried to set my firewall up like the one in the image you posted but it doesn’t seem to have helped. I still get connection resets and timeouts a lot. Is the a guide for connection settings I could review? I’ve searched through the forums, but most of the things I find reference the old version of the program. Thanks.

Is your data rate slow or are just the connections slow to happen? For connections, may be a DNS issue. DNS Client service should be set to automatic. Maybe try a couple of different DNS addresses, like and Are you using the CFP3 default web browser rules?

After messing around with it for hours yesterday, I decided this morning that there are too many variables that could be affecting the problem and I ghosted back the image I was using before I installed Comodo. I’m going to create a new testing partition with a fresh os install on it and try things on there where it should be easier to isolate the problem, should the problem appear again. When I installed it yesterday, I had just uninstalled the previous firewall and virusscan, installed the new NOD32 virusscan and the system had already been tweaked a lot with settings that had worked with the previous configuration but might have been causing problems with the new programs.
Thanks a lot for trying to help me out.

What was your previous firewall? Norton and some others leave behind a bunch of stuff that needs to be removed separately because of conflicts.

I had McAfee before. After I uninstalled it, I booted into safe mode and ran ccleaner and checked to see if there was anything left behind and didn’t see anything, but that doesn’t mean it wasn’t there. I’m hoping that testing it on a fresh install of the os will help. At least then we won’t have to guess about possible conflicts from previous firewalls.