Wired: Removing temp files locks the win 7 x64 OS [NBZ]

This is a very bad bug, it took me hours to fix (till I guessed the issue)

The bug/issue

  1. What you did: Deleted temp files under “C:\ProgramData\Temp”, “C:\Windows\Temp” and “C:\Users[USER]\AppData\Local\Temp”
  2. What actually happened or you actually saw: On restart, system takes +10mn to load, freezing at a black screen after the Welcome message. Once logged, it is slow and network is lost, many apps don’t respond
  3. What you expected to happen or see: My system booting fine after I delete some temp files
  4. How you tried to fix it & what happened: Boot OS in Safe mode and remove cfp registry and process entries
  5. If its an application compatibility problem have you tried the application fixes here?: no compatibility issues
  6. Details (exact version) of any application involved with download link: not I’m aware of, fresh OS install
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: removing those temp files causes the issue, disabling cfp in safe mode solves it
  8. Any other information (eg your guess regarding the cause, with reasons): Why CFP won’t lock its files so they can’t be deleted when cleaning the temp folders???

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: no need, self explaining
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: same as here: https://forums.Comodo.com/bug-reports-cis/cpu-usage-of-25-sometimes-35-cfp-5win7x64defense-in-tarining-t67102.0.html
  3. A CIS config report or file: same as heres: https://forums.Comodo.com/bug-reports-cis/cpu-usage-of-25-sometimes-35-cfp-5win7x64defense-in-tarining-t67102.0.html
  4. Crash or freeze dump file: no crash

Your set-up

  1. CIS version, AV database version & configuration used: CFP 5 last version downloadable + updated
  2. a) Have you updated (without uninstall) from CIS 3 or 4: NO, clean install on new OS
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: NO
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+, Sandbox, Firewall & AV security levels: D+= training , Sandbox= disable , Firewall = custom, AV = NO
  6. OS version, service pack, number of bits, UAC setting, & account type: Win7 x64, UAC default setting, admin account
  7. Other security and utility software installed: Nod32 AV x64 v4.2.67.10 (last version) + updates
  8. Virtual machine used (Please do NOT use Virtual box): NO

[size=10pt]Please, make CFP locks the needed temp files so that they can’t be deleted when cleaning temp folders[/size]

Thank you for your bug report in the required format.

Moved to verified.

Thank you

Dennis